14

Since updating to ubuntu 14.04, every time my Bluetooth device goes idle or I turn it off then back on, it defaults to the Telephony setting and I cannot get it to default to a2dp.

I have searched and only found a couple possible solutions such as Bluetooth speaker: preferred mode “High fidelity playback” (A2DP) is not getting saved but these haven't worked for me. When I use the Disable=Headset as suggested in that post, it works temporarily but after a while, if my device disconnects it will then not reconnect as an audio device.

I'm using Bose Soundlink headphones and my /etc/bluetooth/audio.conf file is as follows:

 # Configuration file for the audio service

 # This section contains options which are not specific to any
 # particular interface
 [General]

 # Switch to master role for incoming connections (defaults to true)
 #Master=true

# If we want to disable support for specific services
# Defaults to supporting all implemented services
#Disable=Gateway,Source,Socket

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
# Defaults to HCI
#SCORouting=PCM

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
[Headset]

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
HFP=false
HSP=false

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=0

# Set to true to enable use of fast connectable mode (faster page scanning)
# for HFP when incoming call starts. Default settings are restored after
# call is answered or rejected. Page scan interval is much shorter and page
# scan type changed to interlaced. Such allows faster connection initiated
# by a headset.
FastConnectable=false

# Just an example of potential config options for the other interfaces
#[A2DP]
#SBCSources=1
#MPEG12Sources=0
1

Using pavucontrol from the pavucontrol package, it is really easy to setup A2DP for your device, and map connections to it. Your paired headphones should appear as an option to output audio.

Don't forget to put it in high quality mode (A2DP) in the configuration tab. This is necessary for some devices that have mixed mode.

Source: https://wiki.debian.org/BluetoothUser/a2dp

  • This allows you to switch to A2DP, but it doesn't fix the issue of the setting being saved. Ubuntu 16.04 has the ability to change to A2DP in the default sound configuration GUI anyway, so no need to install new packages. – silverscania Jan 16 at 13:03
  • @silverscania If you have a new question feel free to ask it. If you have a better answer please don't hesitate to post it after reviewing how to answer. It's entirely feasible I've missed a trick here as I don't have the hardware required to test. If you do, please utilize that edge to help us improve the site. The answer you are seeking may very well be here – Elder Geek Jan 16 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.