1

I followed Ubuntu 12.04 LTS Precise Pangolin: File sharing with Samba by Jonathan Hobson on Sitepoint to try to see my windows workgroup from my Ubuntu 12.04 32 bit machine and now I am locked out as administrator. The steps were to install Samba with Winbind, but it brought up a new login and I don't know how to go back. Before the change my login name was joe with admin privileges and after the admin the name is Joe Fritz but the password is not known and sudo commands say I am not in the sudo list. So can I go back to a working setup? How?

0

Try this.

-Restart your computer (into recovery) -Choose advanced then recovery -Choose command prompt -Mount file system read/write "mount -o remount,rw /" -Rename /etc/samba/smb.conf to something else -Reboot -Choose advanced then recovery then command line -Mount file system "mount -o remount,rw /" -Change your user password back to original with command "passwd " (=YOUR ORIGINAL USERNAME) Now you should be prompted to type the new password TWICE

Don't screw around while your drives are mounted rw & make sure yoou use your original password!

  • Ok, tried all of that with no change. Here is the thing. I had set up a development web server on this machine and set up three accounts for access and testing. After a recent set of updates including the install of samba, the Ubuntu login in shows the three web accounts but not the Ubuntu account. Worse, is that the account tagged as administrator won't accept any of the passwords and none of them have the web server installed. I am dead in the water for development. I have uninstalled samba and turned off winbind, but still no change. I guess I can reinstall Ubuntu and start over! – Joe Fritz Mar 25 '15 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.