Sorry this is so long. If you don't care why I need to run GIMP inside a virtual machine when I could just run it in Windows, or just want to take my word for it when I say that I have no other choice, you can scroll down to the section labeled "The Problem".


I might be the only person on the planet who relies on being able to use GIMP from an Ubuntu 11.04 install inside a Virtual Machine (OpenBox OSE) from Windows 7, but this is my situation.

I work for a small company which has a shared computer for use by myself and several coworkers. Although I have a MAJOR project on the back-burner which sees the company switching over to Linux and implementing a more integrated system, Windows 7 is currently required for the business's use of Microsoft Access.

My coworkers wouldn't even know how to spell "Linux" and do all their work from Windows. I haven't really used Windows in about 4 years other than when using and maintaining the Access databases at work - all of my personal computers run Ubuntu and I'm much more efficient in that environment.

I'm a heavy user of desktop spaces and really have trouble being constrained to the single workspace when running GIMP in 7, and have trouble remembering where to look for files ("My Documents" vs "Home"). For that reason (and because I'm testing other applications for future use by the business) I have Ubuntu 11.04 installed in VirtualBox OSE in which I spend a great deal of time during my shifts. The ability to minimize Ubuntu and return to the Windows environment is unfortunately required as I often need to make use of Access.

I use GIMP to create various advertisements, logos, and other media for the business. I do this in addition to the same work my coworkers are doing so my time for such projects is extremely limited.

The Problem:

When I run GIMP in Ubuntu 11.04 (untested with previous versions of Ubuntu) inside a virtual machine, it seems that the GIMP eyedropper tool thinks my entire screen covered by the default Natty wallpaper and when I use the tool all I get is purple. Fuzzy Select and other tools that require colour recognition do work properly, however.

I think this is more to do with how Virtual Box OSE displays the desktop rather than an issue with GIMP itself. I've seen brief flashes of the Natty wallpaper (not the one in use, by the way), most predictably replacing drop down menus when RAM is low-ish (drop-down box is proper size but displays a piece of the wallpaper instead of the menu).

Has anybody else noticed this and/or know of a way to fix it? It's really hard to match colours by just "eying it"! :P

Running Ubuntu 11.04 64bit (Unity DE) in VirutalBox OSE v4.0.12r72916 (latest), GIMP 2.6.11

  • Thank you for the quick response - updating VirtualBox and Guest Additions did the trick! I greatly appreciate your help, my job just got a lot easier! I'll probably switch to Oneiric in October when it's stable - I've tried the beta at home and, while it performed much better than Natty, I know it isn't ready for use on a business computer. Thanks again for your help! :) – WPIS Sep 5 '11 at 18:12
  • @Takkat: You should probably make your comment an answer so it can be accepted. – Javier Rivera Sep 6 '11 at 6:58
  • Due to popular demand I made my comments an answer ;) – Takkat Sep 6 '11 at 7:23

This is most likely an issue of the Guest Additions graphics driver, that may also depend on the graphics driver from the host. You may want to update Virtual Box to the latest release (at present 4.1.2) including updating Guest Additions.

If this bug is not yet fixed try running 10.04 with desktop effects (Compiz) set to "off".

Side-note: graphics in virtual box will be much better integrated in 11.10 where you will also have the option to run Unity2D. However there are other issues that warrant waiting for the official release.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.