-1

When I opened my computer, it shows the terminal interface.

I don't know why but I think it's due to the many times I opened te terminal and typed lots of commands to fix my wireless network and sounds (which did not work).

After that, I gave up and tried to shut my computer off. But it only showed the user options and it wouldn't shut off. I tried to wait for it to run out of battery since I only had to wait 19 mins but after a while it showed thatI had to wait 24 mins.

So I shut it down by pressing the on button.

Now, I opened it and it only shows a black screen with the same format of the terminal interface.

Plus the computer is a hand me down and my uncle who formerly owned it forgot the password.

I'm no genius when it comes to terminals so I have no idea what to do. Please help me!!

UPDATE: I opened it again and it's now stuck on the ubuntu start up screen with the dots thing. And the terminal thing is there and I have no idea what to do.

I can launch apps through the terminal but it isn't enough, you know?


Okay just to add this information: I also forgot my password. Technically, my uncle did and the computer is a hand me down one. I can't really do much wih prompts since it's password protected sometimes....

  • may be your GUI services are not starting run this command "/etc/init.d/lightdm start" or if you can share screen shot that would be more help full – PKumar Mar 24 '15 at 5:42
  • If you can log in on terminal it may be worth running the command history to give a list of what commands you ran. This list may help identify what went wrong. – Julian Stirling Mar 24 '15 at 5:43
  • May wanna check the grub file , whether or not it's set to boot into console or what not. Among other things , I'd check dmesg and sys logs – Sergiy Kolodyazhnyy Mar 24 '15 at 9:19
  • If you don't have a password for administrative access, the first thing you should do is to reset the password. – David Foerster Mar 24 '15 at 9:34
1

At some point you probably killed the graphical server. This happened to me once when I tried to install the nVIDIA binary drivers. This should help you get it back:

When your computer starts up, login. It will ask you for your username and password. After you are logged in, type in sudo service lightdm restart If you still see the command line, type in startx.

These commands will recover your graphical shell. LightDM is Ubuntu's desktop manager. X is the graphical server that displays all of the windows and desktop effects. Sometimes X11 (the graphical server) crashes or freezes, logging you out into the command line.

Source: http://www.howtogeek.com/119293/4-ways-to-recover-from-a-crashed-or-frozen-x-server-on-linux/

  • 1
    And on the next boot he sees again the terminal. Not very helpful response. – A.B. Mar 24 '15 at 8:25
0

If the answer of Terrance8D didn't helped you at all, then you could try booting Ubuntu from a liveDVD or a liveUSB and see what happens.
The battery situation i just don't understand. What's battery got to do with anything?

"...it's now stuck on the ubuntu start up screen with the dots thing." If you really can see the ubuntu dots you're in great luck. Just create a live DVD/USB like this: Create a live CD/DVD/USB , boot it up and install it from there.

If you can boot Ubuntu in live mode, then the missing password is from the GRUB (the Ubuntu's bootloader) or from Ubuntu itself (rather the later). You can try to rescue your files from the disk while in Live mode and then reinstall Ubuntu and set a new password for Grub (only if you consider necessary).

If you can't boot Ubuntu (or any other linux) in live mode, the situation is a little grim: the missing password belongs to the BIOS/UEFI itself. And that password is coded directly into the hardware (into the BIOS chip to be exact). Very hard to recover. Without BIOS password the computer is in lock down mode. Can't do anything with it at all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.