18

I just bought the new hp spectre x360 dual-core i7, 8 GB ram and 256 SSD. Will Ubuntu run on this computer without issue or is it not yet supported?

  • If you already got the machine with you, you can download it from ubuntu.com and try it. – xangua Mar 24 '15 at 4:34
  • 2
    I'm voting to close this question as off-topic because this is a hardware compatibility question. – Pilot6 Sep 23 '15 at 19:46
  • possible duplicate of Is Ubuntu compatible with my hardware? – karel Sep 24 '15 at 12:21
  • your CPU is a Broadwell or Skylake CPU ? – Yonsy Solis Jul 29 '16 at 15:39
9

EDIT: On recent Arch based Linux it works out of the box (Manjaro & Antergos): as of june 2017 at least

Just installed Ubuntu 14.04.3 LTS on an HP Spectre 360.

All worked great out of the box, except... the sound.

I changed the kernel version to 4.0.9-040009-generic (but I don't think it really helped). It works well anyway.

All forum posts talk about the Dell XPS 13, but they are not working for Spectre.

TL;DR:

The only solution can be found here in the GREY zone:

http://h30434.www3.hp.com/t5/Notebook-PC-Sound-and-Audio/HP-spectre-x360-on-linux/td-p/4980797

Yes, you must reboot 2 time! Weird.

EDIT

Below the essential part: --> It is all about kernel parameters in grub config

HOW TO:

Edit grub config by doing:

sudo vim /etc/default/grub

Edit the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash'"

Replace it with: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi='!Windows 2013' acpi_osi='!Windows 2012'"

Then run: sudo update-grub

Reboot TWO times. Yes. 2 times.

Then Sound works (FYI The sound card is now in HDA mode -not I2S).

To confirm, run: aplay -l and make sure you have the following in the output:

card 1: PCH [HDA Intel PCH], device 0: ALC3242 Analog [ALC3242 Analog] Subdevices: 0/1 Subdevice #0: subdevice #0

When you open the Alsa mixer (the ound mixer settings window), you should see a sound card displayed.

Note: The Added 'acpi_backlight=vendor' parameter apparently do nothing (it is supposed to keep backlight settings?)

EDIT BIS:

The card seems in mute mode as default. You need to setup pulseaudio correctly ( pulsaudio/Alsa ).
With Manjaro OpenRC Linux I had to add the following packages:

  • pulsaudio
  • pulseaudio-alsa
  • pulseaudio-equalizer
  • xfce4-pulseaudio-plugin
  • xfce4-volumed-pulse

then start the pulseaudio server manually

pulseaudio --start

from (https://wiki.archlinux.org/index.php/PulseAudio#Starting_manually)

Now you can successfully launch the pulseaudio mixer (from associated the XFCE4 applet) & go to "output devices" and play with "port" and the sliders.

  • 1
    Can I ask what kind of battery life you get running Linux on this thing? – tobek Jul 7 '16 at 1:13
  • 1
    I can't compare to windows, because I removed it as soon as I got it. – Nadir Jul 7 '16 at 22:37
  • 2
    I would say 5 hours easily, so to me it is a decent battery life (I am sure of it as I often take a 3h trip by train, and there's still fair amount of battery at the arrival ). The question is interesting, I will measure it tomorrow or the day after (Laptp is almost 1y old) The differences over windows: you can't easily set a CPU profile. the only setting available is "dim display" & "reduce backlight on battery". – Nadir Jul 7 '16 at 22:51
  • 4
    I just run the test this morning: 4h with a 100% normal usage : internet, music and coding activities. – Nadir Jul 9 '16 at 11:06
  • 1
    I was curious about it too. Note that I stopped at the autosuspend which was set at 10% of battery. so there was a bit more left.. ;-) – Nadir Jul 9 '16 at 22:21
14

I have tried Ubuntu 14.04.02 via a USB stick on my Spectre x360 (8Gb RAM Intel 5200). As mentioned, secure boot needs to be disabled.

Works without any additional steps: touchscreen, trackpad, windows keys, WIFI, USB, bluetooth, networking, SD card.

Not working: On board sound. HDMI audio is detected, but no other audio device. (So no speakers and nothing out of the headphone out).

-7

Most modern PCs are compatible with Linux. The HP Spectre X360 has Windows 8 installed, so you have to make sure that Secure Boot is disabled. Other than that, Ubuntu will work just fine.

  • 7
    This answer suggests "If it runs windows, don't worry about linux", which is utterly false. The very similar device Dell XPS 13 (2015 edition) requires quite some work to run Linux properly. Will the X360 boot linux? Probably. Will the graphics drivers work? Probably. Will the touch screen work? Maybe. Touchpad? Maybe. Automatic screen rotation? Probably not. Audio? Don't know. It's not this simple. – akkkk Mar 24 '15 at 21:28
  • 2
    @akkkk Okay. Probably should have done some more research before answering. Thanks for correcting me though. – Terrance8D Mar 25 '15 at 0:00
  • I almost bought a Lenovo Yoga 910, but found out just in time that it does not run Linux at all. – Jeroen Kransen Oct 18 '16 at 6:53
  • The HP Spectre x360 has Windows 10, and boots Ubuntu fine with Secure Boot/UEFI enabled. – unhammer Jan 18 '17 at 10:37

protected by Community Oct 10 '15 at 15:01

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.