2

I have the hp stream 11" (11-d010wm) using realtek wifi: RTL8723BE kernel 3.19.2-vivid to fix touchpad issues (I've tried v4.0rc5-vivid also)

I've tried both Ubuntu 14.10 and the latest release of Linux mint cinnamon.

The connection frequently stops responding. Connection manager shows it still connected but no traffic is moving. pinging my home router (or any destination) results in unreachable. I've used both static IP and dhcp.

in Ubuntu I can just disconnect/reconnect and that seemed to work fine. in linuxMint it will ask to re-authenticate wifi password and it will never succeed. restart required.

Initially the connection was lasting for a while (15-30 minutes). But it seems to have increased in frequency (since switching to linuxMint?). Now it seems i can't even stay connected for a couple minutes at a time.

When I boot the machine to windows I do not experience problems. My other windows devices don't experience connectivity issues to the same router over wifi when stream drops.

at this time I managed to install linuxMint without switching from EFI to legacy boot (and leaving secure boot enabled) not sure if that has any impact.

I grabbed this chunk of my logs - I don't recall what all I was doing during this time (probably tried to manually deactivate/reactivate radio before restarting, may have also tried changing network configs).

pastebin.com/ppXfeHnU

this is a really great device for what I wanted to do with it (ssh to my desktop from the couch to do some programming) but the freezing connections makes it unusable in Ubuntu/linuxMint.

I'm not sure what the next step is. maybe trying to find the source files for the drivers and build them on my machine?

  • 2
  • Same problem with HP Stream 13; I don't have an answer, but have more data. I swapped the realtek for an "Intel Corporation Wireless 3160 (rev cb)" and the problem still occurs. For me the problem is a little more specific: it happens after resuming from sleep. After a reboot until I put the laptop to sleep the wireless works fine. I think this may actually be a controller (or whatever is upstream of the newfangled not-PCI wireless cards these days) issue and wonder if a new kernel will fix it. I'm on lubuntu's 3.19.0-47-generic – imjustmatthew Jan 23 '16 at 22:03
  • Happens with lubuntu 4.2.0-25-generic too, so nm that kernel-centric reasoning :( – imjustmatthew Jan 23 '16 at 23:02
-2

According to a reply comment from a review about the ultralight laptop at amazon: http://www.amazon.com/review/R28HR668I6LU8Y/ref=cm_cd_pg_pg6?ie=UTF8&asin=B00NSHLUBU&cdForum=Fx32V5DBEJH4RUL&cdPage=6&cdThread=Tx1I5CUWGAIAGT5&store=pc#wasThisHelpful

The wifi issue can be fixed with a new driver by..... You can get the zip from https://github.com/lwfinger/rtlwifi_new [on the right side of the page about half way down is the download button ]. Now, extract the directory, cd to that directory, type "sudo make", "sudo make install" and reboot. The wifi now seems to be fine.

And for the mousepad right click problems..... To solve the right-click problem I had to modify the settings for synaptics. I copied the file /usr/share/X11/xorg.conf.d/50-synaptics.conf to /etc/X11/xorg.conf.d/50-synaptics.conf. I then changed the line "MatchDriver "synaptics"" with "Option "ClickPad" "on"" and the line "Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0" with "Option "SoftButtonAreas" "50% 0 50% 0 0 0 0 0". After a reboot I could right-click again.

protected by Community Dec 17 '15 at 17:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.