5

How to upgrade the firmware intel WiFi from 7260-10 to 7260-12.

on Intel page said: "Installation of the firmware is simply:"

# cp iwlwifi-*.ucode /lib/firmware

So I have

#sudo ls -al /lib/firmware/iwlwifi-7260-*
-rw-r----- 1 root root 672352 Mar 19 14:19 /lib/firmware/iwlwifi-7260-10.ucode
-rw-r--r-- 1 root root 782300 Mar 19 13:35 /lib/firmware/iwlwifi-7260-12.ucode
-rw-r--r-- 1 root root 683236 Nov 24 15:42 /lib/firmware/iwlwifi-7260-7.ucode
-rw-r--r-- 1 root root 679780 Dec  1 15:16 /lib/firmware/iwlwifi-7260-8.ucode
-rw-r--r-- 1 root root 680508 Dec  1 20:45 /lib/firmware/iwlwifi-7260-9.ucode

But I doesn't load the last version 7260-12, trying to reboot but no luck it stays with 7260-10 .

sudo dmesg | grep iwl
[    4.673076] iwlwifi 0000:03:00.0: found PCI INT A -> IRQ 10
[    4.673090] iwlwifi 0000:03:00.0: sharing IRQ 10 with 0000:00:1c.1
[    4.680093] iwlwifi 0000:03:00.0: loaded firmware version 23.15.10.0 op_mode iwlmvm

and

modinfo iwlmvm 
filename:       /lib/modules/3.19.0-6-generic/updates/drivers/net/wireless/iwlwifi/mvm/iwlmvm.ko
version:        backported from Linux (v3.19-rc1-0-g97bf6af) using backports v3.19-rc1-1-0-g74aaf28

I have unstable WiFi connection.

4

Have you tried

sudo cp /lib/firmware/iwlwifi-7260-10.ucode /lib/firmware/iwlwifi-7260-10.ucode.bak
sudo cp /lib/firmware/iwlwifi-7260-12.ucode /lib/firmware/iwlwifi-7260-10.ucode

Then reboot, renaming the file works sometimes

You could edit the source from the backports by going into the backports directory and into /driver/net/wireless/iwlwifi and edit iwl-7000.c line 72 as it should be

#define IWL7260_UCODE_API_MAX   10

and change it to

#define IWL7260_UCODE_API_MAX   12

Save and exit text editor, then you can

make clean
make defconfig-iwlwifi
make
sudo make install

and see if it will load the 12.ucode without changing file names.

  • thanks you, it loads the 7260-12 but the WiFi still unstable I think I need to downgrade to 7260-9 or 7260-8, do you have any suggestion ? – enjoy Mar 24 '15 at 12:24
  • You could do another edit of the source code to line 80 to change it from 9 to 8 and save and reinstall the backports. Then check /lib/firmware and delete or rename the iwlwifi-7260-10.ucode, iwlwifi-7260-11.ucode, and iwlwifi-7260-12.ucode and see how it works with the iwlwifi-7260-9.ucode after a reboot – Jeremy31 Apr 10 '15 at 20:50
  • @Jeremy31: Hi! Thanks for the answer. I encounter exactly the same problem as the OP, but the iwl-7000.c doesn't seem to appear on my system. What am I supposed to do? – Sam Bruns Sep 22 '15 at 9:13
  • @SamBruns iwl-7000.c is a kernel source code file. The backports likely are already patched to use the 7260-12.ucode file – Jeremy31 Sep 22 '15 at 10:01
  • 1
    Ask a new question so there is room for the answer. Have you tried renaming the 12.ucode file to a lower number to see if it will load? – Jeremy31 Sep 22 '15 at 10:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.