6

I have a desktop which dual-boots to Kubuntu 14.04 by preference, or Windows 7. My wife has an iMac desktop and we have various Wi-Fi tablets and phones. We have a Technicolor tg582n router to which the desktops are connected by ethernet through TP-Link PA211 "Powerline" Home plugs; we use two TP-Link WPA271 Home plugs for Wi-Fi in the parts of the house not reached by the TG582n.

I recently reset the five TP-link devices because our broadband kept dropping out. They now have factory default settings except for a password for security on the Wi-Fi devices. We now have broadband on all devices (including my desktop on Windows) at about 16Mbps, the speed advertised by our ISP and ample for our use. There is one exception: whereas I had an excellent Ethernet connection on Kubuntu before, I now need to use a Wi-Fi dongle and it is noticeably slower. Any help much appreciated. To make this clear, I only need the dongle because Kubuntu won't now connect by Ethernet, as it did before I reset the home plugs. Before, my desktop connected by ethernet in Windows and Kubuntu; now only Windows connects by Ethernet.

The dongle is OK, the problem is that WiFi is always slower than Ethernet.

Edit: Now getting 14Mbps download but still stuck on @Fabby's stage 4. Output of ifconfig:

WGCman@WGCman-XXXX-D3:~$ 

sudo ethtool --change eth0 speed 100 duplex full autoneg off

[sudo] password for WGCman: 

 WGCman@WGCman-XXXX-D3:~$ ifconfig

eth0      Link encap:Ethernet  HWaddr fc:aa:14:06:xx:xx  
      inet addr:192.168.1.70  Bcast:192.168.1.255  Mask:255.255.255.0
      UP BROADCAST RUNNING MULTICAST  MTU:100  Metric:1
      RX packets:88065 errors:0 dropped:0 overruns:0 frame:0
      TX packets:46875 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:22091647 (22.0 MB)  TX bytes:3947548 (3.9 MB)

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:1928 errors:0 dropped:0 overruns:0 frame:0
      TX packets:1928 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:283489 (283.4 KB)  TX bytes:283489 (283.4 KB)
2
  • 1
    You have 16 Mbps with Windows + WIFI, where in Kubuntu you have less, right? Maybe the problem is with the WIFI dongle drivers. Would it be great if you edit your comment and add some info about your drivers. – Zaka Elab Mar 23 '15 at 11:48
  • In the /etc/NetworkManager/system-connections folder you have all the settings for any connection that you ever established. Try disconnecting your machine from wifi or ethernet, deleting every single file in that folder (you'll need sudo for that), and then reconnecting with ethernet. Among other things, check output of rfkill list all, and let us know what it says. – Sergiy Kolodyazhnyy Mar 28 '15 at 3:31
3
+25

You should turn off auto-negotiation on the machine and fix the network speed to the highest level that the Network Interface Card (NIC) can sustain on your powerline adapter.

Start with 10Mbps, half duplex and work upwards to 10Mbps FD, 100Mbps HD, ... until the problem starts. Then go down one notch and leave it at that speed.

First, install ethtool (if already installed you will just get a warning that the latest version is already installed)

sudo apt-get install ethtool

Now:

  1. Type the following command (and test them one by one)

    sudo ethtool --change eth0 speed xxx duplex yyy autoneg off
    

    where xxx = 10, 100 or 1000 and yyy = half or full.

    So start with 10 half, 10 full, 100 half, ...

  2. Do an ifconfig to check whether you got an IP address.

  3. Go back to 1 until it stops working and use the previous values that still worked to:

  4. To make the change permanent, execute the following command:

    sudo nano /etc/network/interfaces
    

    and type at the pre-up section:

    pre-up /usr/sbin/ethtool --change eth0 speed xxx duplex yyy autoneg off 
    
4
  • Thank you @Serg. Unfortunately rfkill list all returned nothing but the $ prompt. – WGCman Mar 29 '15 at 17:08
  • 2
    Thank you, @Fabby. Setting speed to 1000 gave an “Invalid parameter” message. 100 speed full duplex gave a download speed of 5Mbps, no faster than the wifi dongle. However, 100 half duplex gave over 15Mbps, which is fine as our ISP gives 16! However where is the “pre-up” section? sudo nano /etc/network/interfaces returns : # interfaces(5) file used by ifup(8) and ifdown(8) auto lo iface lo inet loopback ^G Get Help ^O WriteOut ^R Read File ^Y Prev Page ^K Cut Text ^C Cur Pos ^X Exit ^J Justify ^W Where Is ^V Next Page ^U UnCut Text^T To Spell – WGCman Mar 29 '15 at 17:25
  • 2
    I can edit my answer to be more specific to your set-up if you add to your question the output of ifconfig... ;-) And don't thank me! ;-) If you like my answer, just click the little grey under the "0" now turning it into beautiful green. If you do not like my answer, click on the little grey down-arrow below the 0, and if you really like my answer, click on the little grey checkmark and the little up-arrow... If you have any further questions, go to askubuntu.com/questions/ask – Fabby Mar 29 '15 at 20:43
  • 1
    @WGCman: If this answer helped you, don't forget to click the grey at the left of this text, which means Yes, this answer is valid! ;-) – Fabby Aug 30 '15 at 11:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.