2

I've never posted here before but I've been unable to find any solutions online so I thought I would ask.

I have a desktop and a laptop, both running ubuntu 14.10. I first noticed that youtube videos weren't playing in firefox on my desktop a couple of days ago. Instead of playing, I'd get the message "an error occured, please try again later." Even though I had the flash plugin for firefox and chrome installed from the ubuntu software center, flash had stopped working in firefox. However, it was still working in chromium. Today I only have access to my laptop, but I've just noticed that the flash plugin has stopped working in firefox. In Chromium, youtube videos will play, but the shockwave flash plugin for games has stopped working. I get an error message that shockwave flash has stopped responding.

I'll also mention, since I'm unsure if it's related, that up until a day or so ago I was using a custom theme on my ubuntu desktop (numix), but after a software update I lost the ability to change the theme and my desktop had reverted back to the default theme (switching to gnome from unity allowed me to change the theme again, but in unity I was stuck with the default theme). It was at this time that I noticed flash had stopped working.

I have tried updating both web browsers and reinstalling the flash plugin through the software center. I also tried installing flash directly from the flash website using the downloadable tar.gz file, but I'm not sure if I installed it correctly since I was trying to follow instructions I had found online on how to install a tar.gz.

Does anybody have any ideas as to how I can fix these issues? I've been unable to find any threads made by people experiencing the same problem, which is what I usually look to for answers.

  • Visit youtube.com/html5 and enable html5 video player. – Helio Mar 22 '15 at 17:41
  • when I view videos in HTML5 on youtube they are far more choppy and laggy than when I was using the flash plugin. I'd much prefer a fix to this problem than a work-around. – Alex Mar 22 '15 at 17:42
1

Try installing flash with this command:

sudo apt-get install flashplugin-installer
  • thank for the reply! I feel like I should have thought of that before posting here... nevertheless it worked! Now if only I could figure out that theme issue with unity on my desktop. – Alex Mar 22 '15 at 18:13
0

YouTube now will use HTML5 Video Player as the default video player.

Depending on your Firefox version (I have Firefox 36.0.4 now) there is video support for HTML5 Video Player .

And no, it's not a workaround, read the first link, flashplugin-installer is a workaround now, because flash is not updated in Linux, only with pepperflash inside Chrome and reuse for Firefox (that is another workaround PPA).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.