1

Please help me. I have ubuntu 14.04. When I use nouveau driver gpu temperature don't up more then 70°C. But when I switch to nvidia-331-proprietary my temperature jump to 90°C or even higher when start 3D app's. I have lenovo g560, nvidia 310m, without optimus.

  • Of course the proprietary drivers can use the features of your card better and generate a higher usage and therefore a higher temperature, but 90°C is shortly before smoke... You should check your cooling system (fans, heat sink, thermal paste, whatever... Start with a vacuum cleaner). – Byte Commander Mar 22 '15 at 14:16
  • Take a full system back-up (choose User type 4) and then use [this Q&A](askubuntu.com/questions/61396/… to install the NVidia drivers. The 346.47 runs about 10°C cooler then the 331... Leave a comment @Fabby if that wouldn't solve the problem. – Fabby Mar 25 '15 at 18:45
0

You could try running:

nvidia-settings

And under the PRIME Profiles tab on the left of the Nvidia settings window switch to your Intel GPU instead of Nvidia GPU. This will turn off the graphics card and help with cooling, but isn't going to help with cooling when you want to use the graphics card.

Though you can change settings there to limit how much power the graphics card will use.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.