I've just installed Ubuntu today and was wondering why under displays the highest resolution available to me is 1920x1080? In Windows there were much higher ones.

I'm using the default video driver, HDMI cable and this monitor.

My videocard is NVIDIA Corporation GK106 [GeForce GTX 660] (rev a1).

$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 608mm x 345mm
   1920x1080      60.0*    50.0     59.9     30.0     24.0     30.0     24.0  
   1680x1050      59.9  
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1440x900       59.9  
   1280x800       59.9  
   1152x864       75.0  
   1280x720       60.0     50.0     59.9  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   720x576        50.0  
   720x480        60.0     59.9  
   640x480        75.0     72.8     66.7     60.0     59.9  
   720x400        70.1  
DP-1 disconnected (normal left inverted right x axis y axis)
DVI-D-1 disconnected (normal left inverted right x axis y axis)

With my current setup, while using Windows, I was able to use much higher resolutions.

How can I help my system detect that my monitor/videocard can handle a higher one?

2 Answers 2


So I have ended fixing this issue by plugging in the monitor via display port instead of using an hdmi cable.

It's still interesting that on Windows, via hdmi I was able to get resolutions up to 2560x1440.


The default Nvidia graphics drivers for Ubuntu 14.04 do not support resolutions above 1920x1080 on HDMI. To solve this, you have to install the latest Nvidia graphics drivers.

One solution is to add the xorg-edgers ppa and install nvidia-346 with apt-get install by doing:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get install nvidia-346
sudo reboot

Or by downloading the latest drivers from nvidia.com and install them from the TTY, to do this first save everything you are doing on your computer as we have to disable the x display server which will close your GUI and all applications, then press Ctrl+Alt+F1 and login with your username and password. Now enter the following commands:

sudo service lightdm stop
cd /path/to/download/directory
chmod +x NVIDIA-Linux-x86_64-346.35.run
sudo ./NVIDIA-Linux-x86_64-346.35.run
sudo reboot

After rebooting the system you will be running the latest graphics drivers and will be able to set resolutions higher than 1080p.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.