1

I moved from 12.10 to 14.04 and have a Canon Canoscan LiDE 25. It worked fine with Xsane on 12.10.

Now I have the strange effect that I can use the scanner with scanimage all the time, but as soon as I use Xsane or any other frontentd, it does only produce black images (the scanner does not move at all). Occationally I can scan once (mostly preview) and the second attempt produces only black again. I can use scanimage afterwards and it is fine.

Seems to be a kind of reset problem to me, because when Xsane comes up and the scanner makes a short noise, the first scan seems to work. Also when you scan, the scan arm does not return to the start position. Afterwards it creates black images.

The reset problem occurs with other front-ends as well.

Suggestions welcome. Running the latest 1.0.25 sane version (compiled from source). Also the default install did not work before, hence I tried my luck with latest.

Any debug help welcome.

3

Ok. Solved the mystery myself. It is related to USB autosuspend. It seems to kick in too early and the UIs do not wakeup the device properly, only scanimage does it.

I use TLP to control powersaving settings. So I got the device id using lsusb and added it to the USB_BLACKLIST line of the tlp configuration file found at /etc/default/tlp. Works as expected right now.

Took my 10 hours to figure it out, because similar cases had always some different reasons or stayed unanswered.

There is probably a different way to put the device on the blacklist. TLP was the most convenient for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.