0

I use Chromium and Opera browsers in my VirtualBox v.4.3.26 (Ubuntu 14.04 Gnome), but few days ago (not clear, whether after an update or I inadvertently changed some settings) they started to behave as browsers in a smartphone(?).

  • right-clicking with mouse there is no reaction;
  • when scrolling with mouse it either selects the text or images where the cursor is, or when just scrolling over a link it would go to the linked site;
  • in search tabs, when double-clicking it would show one or two blue drops below the search tab, and there is a text (Cut | Copy | Paste | ...) above the search bar.

http://tinypic.com/r/jqgikp/8

https://i.stack.imgur.com/ivqci.jpg

I've already tried to purge and reinstall Chromium, but the same smartphone-like behavior appeared again. I also use Firefox browser which is running fine.

Thank you for any suggestions on how to solve this issue!

4
  • What is the resolution of your virtual machine set to? Some browsers use the resolution of your display to try and determining whether or not you are mobile.
    – user323419
    Mar 27, 2015 at 21:36
  • @Donald the resolution is set to 1366x649 imgur.com/8khwM3H but I also tried to reset it to the original resolution of my laptop 1366x768 imgur.com/FcAZj03 and after the restart, it displayed the same smartphone-like behavior. Any suggestions?
    – peter b
    Mar 28, 2015 at 13:51
  • Well, that's not it then... I am stumped. Sorry!
    – user323419
    Mar 28, 2015 at 13:52
  • @Donald so it seems it is a known issue by chromium developers related to virtual machine and Chromium 41 code.google.com/p/chromium/issues/detail?id=456222
    – peter b
    Mar 28, 2015 at 17:28

1 Answer 1

1

The solution proposed in Chromium Issue 465660 worked for me. Go to Terminal and run

sudo gedit /usr/share/applications/chromium-browser.desktop

Find this line in the file:

Exec=chromium-browser %U

Then replace it with:

Exec=chromium-browser --touch-devices=123 %U

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .