I was installing 32-bit Ubuntu(ubuntu-10.10-desktop-i386.iso) on VMWare workstation 7.1. During installation an error came up with the following text.

(initramfs) mount: mounting dev/loop0 on //filesystem.squashfs failed: Input/Output error Can not mount /dev/loop0 (/cdrom/casper/filesystem.squashfs) on //filesystem.squashfs

I did a memory test which was successful, but when selecting "Try Ubuntu without installing", "Install Ubuntu" or "Check disk for defects" the same error is showing up.

I download the ISO image from Ubuntu website "http://www.ubuntu.com/desktop/get-ubuntu/download". As I couldn't find the checksum data, the ISO image was verified by mounting to a virtual drive and browsing the contents.

The ISO image is mounted to a virtual drive in VMWare and not burnt to a CD.

  • It looks like a corrupt image. Anyway, what is your guest OS?. Oct 11, 2010 at 16:13
  • I have the same problem but on my machine i dont have an operatiing system how can i install ubuntu? really frustrating i cant get the windowsa working on my machine nor i cant get the ubuntu installed
    – user10327
    Feb 6, 2011 at 21:50

4 Answers 4


The checksums (MD5) can be found on releases.ubuntu.com. I would suggest you do the following:

  1. Check that the MD5 checksum of the ISO image you downloaded matches the one in the aforementioned link, by following these directions.
  2. If that looks okay, boot the CD and press the Spacebar key when you see the keyboard icon in the bottom-center of the screen. Select your language, then the "Check CD for defects" boot option.

If neither of those produce any errors, please file a bug here, following these instructions to attach /casper.log to it.

  • on the cd I created today there is no "Check CD for defects", there is "Check disc for defects" though -- leaving me with the question does that refer to cd or hard drive? In any case when I pick it I get the same failure message as in the question. Oct 27, 2010 at 19:55
  • ...and after checking md5sum discovered the iso was bad. Thanks for the good answer. Oct 27, 2010 at 20:05

Did you check the download prior to burning?

You can use a program such as winMD5Sum in Windows to check md5sums

enter image description here


The hashes you need to check against the downloaded iso can be found here https://help.ubuntu.com/community/UbuntuHashes

If you downloaded with a torrent then it should be checked as it downloads though.

If the hash check is ok then reboot with the cd and check it's integrity.

Press any key as the cd loads to see the cd menu

enter image description here


There are two common culprits of this error:

  1. The CD or disk you burnt to did not have enough space for the entire .iso.
  2. The .iso you downloaded had a problem when downloading.

Make sure you at least do these simple checks when going to install:

  1. Check that the size of the downloaded .iso isn't ridiculous (Ubuntu 10.x and 11.04 are each approximately 680 MB, if yours is only like 400 MB, you obviously have a problem).
  2. Check the amount of free space on your CD or disk before you burn to it (and remember, DVDs have lots more space than a generic CD).
  • I have the same problem. Checked the checksum and it's correct. I'm booting from a Kingston USB drive with lots of room (8GB). Can you explain perhaps what is the source of this error. No-one has yet explained here what throws the error? Can it not write to a file? Can it not read a file? What does 'mount' mean? What is it trying to do but can't? Mar 28, 2019 at 19:08

If you are sure about downloaded ISO as @Evan said, try another way to make your USB bootable, for example, if you are using UUI, it is better to use Rufus. However, if your problem did not solve, when the "install, try ubuntu live, etc" page appeared press "e" for editing and add acpi=off, it worked for me!


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .