0

After first install of Ubuntu 14.04.2 LTS on brand-new HP Zbook 15 G2 I wanted to listen to music. Sound works. However, there is a constant, quite strong very annoying noise.

This noise appears only when I use headphones. And the volume of this noise seems to be independent of the volume I chooses on the system. It is there permanently.

(it's really annoying, making this perfect machine unusable in this regard)

It seems to be along the lines of this post: Strange noise in headphones when no sound is played

So here is my output when I run

sudo aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3228 Analog [ALC3228 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 11: HDMI 5 [HDMI 5]
Subdevices: 1/1
Subdevice #0: subdevice #0

Another fact: There are apparently 2 cards installed, but only one is showing up under System->Sound.

Edit: I am using the normal analog 3.5mm headset port on the right hand side. I can confirm, that it is not a problem of the headphones, I tested it with 3 different ones. Same result. Annoying noise. It seems to be a mix of white noise and some other varying frequencies.

Also, if I run the volume all the way down to mute, the noise stops. (which seems to confirm a software/driver problem right?)

2nd edit: There seem to be 3 audio devices:

00:1b.0 Audio device [0403]: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller [8086:8c20] (rev 04)
Subsystem: Hewlett-Packard Company Device [103c:2253]
Flags: bus master, fast devsel, latency 0, IRQ 52
Memory at c0330000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel

and

01:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Cape        Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] [1002:aab0]
Subsystem: Hewlett-Packard Company Device [103c:2254]
Flags: bus master, fast devsel, latency 0, IRQ 53
Memory at c0240000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel

and an unrecognised RealTek card:

5f:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5249 (rev 01)
Subsystem: Hewlett-Packard Company Device 2253
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 47
Region 0: Memory at c0000000 (32-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>
Kernel driver in use: rtsx_pci

maybe I have to disable the one from my AMD graphics card (which is not yet supported in linux anyway) ?

Ubuntu 14.04 installed the following graphics driver by default: Gallium 0.4 on AMD CAPE VERDE

Edit 16.12.2015: Upgrading to 15.10, and the issue stays the same

  • 1
    Is the noise still present when you attach the headphones to another system? Are you using the analog audio jacks? Have you done anything to confirm that the headphones themselves are not the problem? Please edit your question and include all relevant information. This will help us help you! – Elder Geek Mar 21 '15 at 15:36
  • Maybe I have to disable the other soundcards? I think this should be solvable, since HP claims to support Ubuntu 14.04 on this machine ! – eric Mar 22 '15 at 9:03
  • Are you using Pulse Audio? – Elder Geek Mar 23 '15 at 12:32
  • yes I am, See the full readout of my stystem and settings: bugs.launchpad.net/ubuntu/+source/linux/+bug/1434963 – eric Mar 23 '15 at 16:40
  • I had issues with my HP Zbook 15 G2. With the latest bios it has resolved alot of my issues. h20564.www2.hp.com/hpsc/swd/public/… – user400856 Apr 23 '15 at 14:27
0

The following two commands solved this problem for me on my 820 G2:

hda-verb /dev/snd/hwC1D0 0x0c SET_AMP_GAIN_MUTE 0x5180
hda-verb /dev/snd/hwC1D0 0x0c SET_AMP_GAIN_MUTE 0x6180

I added them to rc.local and a pm script for thaw/resume.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.