I have got a brand new Lenovo X1 Carbon 2015 with IPS Display which is really a great laptop. But when installing ubuntu there are some problems I have already solved and some I have not. I put this all in one questions as this might be a good reference for other users.

I have installed a fresh copy of ubuntu 14.04.02

Wifi is disconnecting

Wifi works first but is disconnecting after less than five minutes. If it disconnects it can't see the SSID anymore.

lspci | grep Wireless

04:00.0 Network controller: Intel Corporation Wireless 7265 (rev 3b)

Clickbuttons are not working at all

The Touchpad and trackpoint are working fine. The clickbuttons do not work. In some Programs they do a scroll down/scroll up.

Vertical Scrolling

After fixing the clickbuttons with psmouse proto=imps the trackpoint in combination with the middle button does no vertical scrolling

Special Keys (like Brightness)

Some keys like Volume up/down work out of the box, most don't (mute, Brightness, Wifi).

Screen Characters scrambled on 14.10

On 14.10 sometimes most characters on the screen are just simply gone or scrambled. It looks really weired.

UNRESOLVED: Trackpoint Sensitivity

With other thinkpad models you can control the sensitivity of the trackpoint with /sys/devices/platform/i8042/serio1/serio2/sensitivity

This file ist not available for me. I searched /sys/devices for a file called sensitivity without success.

  • 1
    I feel that it would be better to deal with each of those (mostly) unrelated issues in individual questions. Can you please remove all but one of them from this question and move them to new ones? Mar 21, 2015 at 9:52
  • 2
    @DavidFoerster Usually you are right. But for users having exactly this laptop it is great to have everything in one place.
    – Janning
    Mar 23, 2015 at 20:56
  • At least the wifi is still turning off in a fresh 15.04 installation. The below fix works for that. Also the wifi button does not work. The trackpoint works, as do the trackpad buttons. Scrolling with two fingers on the touchpad works.
    – simbabque
    Sep 26, 2015 at 13:40

6 Answers 6


I recently purchased an X1 Carbon 3rd generation. I fought the issues you mention plus a few more. I kept a text log of all of the fixes and post as follows -

TrackPad Buttons:

  • /etc/modprobe.d/touchpad.conf:

    options psmouse proto=imps
  • update-initramfs -u

vertical and horizontal scrolling


create /usr/share/xsessions/mouse.sh (sudo chmod +x mouse.sh) with the following content:

xinput set-prop "PS/2 Synaptics TouchPad" "Evdev Wheel Emulation" 1
xinput set-prop "PS/2 Synaptics TouchPad" "Evdev Wheel Emulation Button" 2
xinput set-prop "PS/2 Synaptics TouchPad" "Evdev Wheel Emulation Timeout" 200
xinput set-prop "PS/2 Synaptics TouchPad" "Evdev Wheel Emulation Axes" 6 7 4 5

Backlight Brightness


  • /etc/default/grub:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
  • update-grub

  • sudo gedit /etc/rc.local

  • echo 167 > /sys/class/backlight/intel_backlight/brightness

fingerprint reader


$ sudo apt-get install libmagickcore-dev
$ sudo apt-get install libusb-1.0.0-dev libnss3-dev libglib2.0-dev
$ sudo apt-get install libxv-dev
$ sudo apt-get install libtool
$ sudo apt-get install fprintd
$ sudo apt-get install automake
$ cd ~/Downloads
$ unzip fprint_vfs5011-faa090818200ca3ea6bfac8bb510e5e01a246c34.zip
$ cd fprint_vfs5011-faa090818200ca3ea6bfac8bb510e5e01a246c34
$ ./autogen.sh
$ ./configure
$ make
$ sudo make install
$ sudo cp /lib/udev/rules.d/40-libfprint0.rules /etc/udev/rules.d/
$ sudo vi /etc/udev/rules.d/40-libfprint0.rules
# Validity VFS5011
SUBSYSTEM=="usb", ATTRS{idVendor}=="138a", ATTRS{idProduct}=="0017", ATTRS{dev}=="*", ATTR{power/control}="auto", MODE="0664", GROUP="plugdev"
$ sudo apt-add-repository ppa:fingerprint/fingerprint-gui
$ sudo apt-get update
$ sudo apt-get install libbsapi policykit-1-fingerprint-gui fingerprint-gui
$ fingerprint-gui

wifi disable 11N

  • add the following line in /etc/modprobe.d/iwlwifi.conf:

    options iwlwifi 11n_disable=1
  • Excellent. I added your vertical scrolling solution to my answer and marked it as community wiki, so we can bundle all changes there. I needed to adapt it for me on ubuntu 14.04
    – Janning
    Mar 23, 2015 at 20:54
  • What are using the fingerprint reader for?
    – Janning
    Mar 23, 2015 at 21:09
  • Janning, it works for login, resume from hibernate and suspend, and sudo. does not work for synaptic. Thanks for function button solution. Pathetic that 11n is so unstable.
    – brett
    Mar 24, 2015 at 7:36
  • What adds Backlight Brightness? With my function key solution I can use the brightness keys and it shows the current selection in the notification area (OSD feedback). Does your solution adds something to it?
    – Janning
    Mar 24, 2015 at 8:23
  • Mine does not add the use of the function keys. It adds an applet to panel to adjust the brightness and a default brightness setting (the code: echo 167 > /sys/class/backlight/intel_backlight/brightness). I have not tried your function key fix. Does it retain backlight settings on re-boot? This is a good thread btw. Nice to have all of these fixes in one place.
    – brett
    Mar 24, 2015 at 16:50

Wifi is disconnecting

Open a Terminal with Ctrl + Alt + T and enter

sudo su
echo "options iwlwifi 11n_disable=1" >> /etc/modprobe.d/iwlwifi.conf
update-initramfs -u

You can try to use "11n_disable=8" to gain more speed as suggested in a comment. For me it didn't work as my wifi is unstable with "11n_disable=8" but your mileage may vary. I have no speed problems and no interrupt problems with "11n_disable=1".

Clickbuttons are not working at all

Open a Terminal with Ctrl + Alt + T and enter

sudo su
echo "options psmouse proto=imps" > /etc/modprobe.d/psmouse.conf
echo thinkpad_acpi > /etc/modules-load.d/thinkpad_acpi.conf
echo "options thinkpad_acpi force_load=1" > /etc/modprobe.d/thinkpad_acpi.conf 
update-initramfs -u

With this your buttons are working again. But you can't click on the complete touchpad anymore. Just the bottom of the touchpad recognizes clicks. But that's fine for me.

But the vertical scrolling with the middle button/trackpoint is not working. See below.

Special actions on Function keys

Open a Terminal with Ctrl + Alt + T and enter

sudo su
echo thinkpad_acpi > /etc/modules-load.d/thinkpad_acpi.conf
echo "options thinkpad_acpi force_load=1" > /etc/modprobe.d/thinkpad_acpi.conf 
update-initramfs -u

The special actions like Volume, Brightness, Beamer and Wifi toggle on F1-F8 are working now as expected. Special actions on F9-F12 are not working.

By the way: "FnLk" on the Esc Key means "Function Lock". You can activate the Function Lock with pressing Fn + Esc.

The brightness setting is not retained after a reboot.

Vertical Scrolling

Open a Terminal with Ctrl + Alt + T and enter

sudo su
export FILE="/etc/X11/Xsession.d/99trackpoint"
echo 'xinput set-prop "PS/2 Synaptics TouchPad" "Evdev Wheel Emulation" 1' > $FILE
echo 'xinput set-prop "PS/2 Synaptics TouchPad" "Evdev Wheel Emulation Button" 2' >> $FILE
echo 'xinput set-prop "PS/2 Synaptics TouchPad" "Evdev Wheel Emulation Timeout" 200' >> $FILE
echo 'xinput set-prop "PS/2 Synaptics TouchPad" "Evdev Wheel Emulation Axes" 6 7 4 5' >> $FILE

After rebooting you have vertical and horizontal scrolling with trackpoint and middle button.

Screen characters scrambled

Open a Terminal with Ctrl + Alt + T and enter

sudo su
mkdir /etc/X11/xorg.conf.d/
cd /etc/X11/xorg.conf.d/
echo 'Section "Device"'                      > 20-intel.conf
echo '    Identifier  "Intel Graphics"'     >> 20-intel.conf
echo '    Driver      "intel"'              >> 20-intel.conf
echo '    Option      "AccelMethod"  "uxa"' >> 20-intel.conf
echo 'EndSection'                           >> 20-intel.conf

Screen characters are not scrambled anymore.

  • And you're fixing all the wifi problems only disabling the n band?
    – 0x2b3bfa0
    Mar 21, 2015 at 9:53
  • Yes, I fixed wifi for me. It is very stable after disabling 11n
    – Janning
    Mar 21, 2015 at 10:11
  • What wifi card is?
    – 0x2b3bfa0
    Mar 21, 2015 at 10:13
  • @Janning I would edit the conf file and change it gksudo gedit /etc/modprobe.d/iwlwifi.conf and change it from 11n_disable=1 to 11n_disable=8 then save, exit, and reboot as it usually works with the Intel cards
    – Jeremy31
    Mar 21, 2015 at 11:44
  • @Jeremy31 what is the benefit of 11n_disable=8?
    – Janning
    Mar 23, 2015 at 21:06

I'd just post this as a comment but don't have the rep. I've been making tweaks based on this post since I got the 2015 X1 Carbon, but hadn't solved everything. I started over yesterday with a completely fresh Vivid install and was pleasantly surprised to find zero issues, as in "just works."

In particular, the click buttons and trackpad are recognized and configurable under "Mouse and Touchpad" settings. Middle-click touchpoint and two-finger touchpad scroll work as expected.

This doesn't exactly solve the OP's problems with 14.04, but may be helpful to others who find this post.

  • Thanks, very useful. Can you comment on back light brightness and Wifi radio keys? I wanted the 5 year support cycle so I opted for 14.04 over 14.10. What happens at the end of 15.04's 9 month support cycle?
    – brett
    May 10, 2015 at 19:28
  • Vivid recognized the function keys for the back light properly. The on-screen sun icon and slider appear and I'm able to adjust the brightness. The brightness level survives after sleeping and resuming. Tapping the radio key toggles airplane mode, in which the wifi and bluetooth radios are shut down. Something I've noticed since posting is that I can't sleep the machine using my GNOME menu. I didn't realize this at first because closing the lid sleeps and opening it resumes, per my power settings, and it isn't a problem for me.
    – effel
    May 17, 2015 at 20:41
  • I had many of the same issues as the OP with my x1 carbon--the character scrambling was especially bad. Installing 15.04 was what I found to fix all the issues i was having Jun 4, 2015 at 21:13
  • I made the switch to 15.04 from 14.04 about one month ago and can confirm that the wifi, trackpad and brightness problems are fixed. Have not tested the camera key. I initially upgraded from 14.04 to 15.04 however did not achieve desired results and resorted to clean install of 15.04.
    – brett
    Jul 5, 2015 at 10:13

Here is my solution to the brightness issue:

#include <stdio.h>
#include <stdlib.h>
#include <sys/types.h>
#include <unistd.h>

int main(int args, char **argv)
    FILE *f;
    int cur_br, new_br;

    char cmd[256] = { 0, };
    if (args <= 1 || strnlen(argv[1], 256) >= 256) {
            printf("Set the screen brightness:\n\tbr 0-852 or [+-]\n\n");
    f = fopen("/sys/class/backlight/intel_backlight/brightness", "r+");
    if (f) {
            fscanf(f, "%d", &cur_br);
            fprintf(stderr, "%d\t%s", cur_br, argv[1]);
            if (strncmp(argv[1], "-", 1) == 0) {
                    new_br = (int)((float)cur_br / 1.1);
            } else if (strncmp(argv[1], "+", 1) == 0) {
                    new_br = (int)((float)(cur_br + 1) * 1.1);
            } else {
                    new_br = atoi(argv[1]);
            if (new_br < 0) {
                    new_br = 0;
            } else if (new_br > 852) {
                    new_br = 852;
            fprintf(stderr, "\t%d\n", new_br);
            fprintf(f, "%d", new_br);
    return 0;

I have no idea why 852 is the magic number for max brightness (deduced it via trial and error). I bound my brightness keys to call this executable (has suid set) with either + or - as args. If you accidentally set brightness to 0 :D you can always execute with 500 (or 852) as the param.


I have x1 carbon 3rd gen too, I have tinkered around it for long now and posting so people could prevent searching allot and finding nothing. In my case I have ubuntu 15.04 with kernel 3.19.0 and firmware version instead of the latest one I downloaded kernel 3.17.0 compatible from here for a wifi 7265 model https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi the one that says 10.ucaf

just extract it out and copy both ucaf files to /lib/firmware but you might need to delete other ucaf drivers for the model you have, so the 10th one gets loaded. I found this through trial and error and my wifi is at last stable... good luck to all, my point is that 15.04 works better on x1 carbon 3rd gen (everything except of maybe wifi works out of the box on kernel 3.19.0 with which this version of ubuntu comes with)


Ubuntu 14.04.4 LTS works out of the box

With the latest Ubuntu 14.04 with the most recent hardware enablement stack and kernel there are no issues at all. All of the issues mentioned above have not occurred :) The actual kernel version is:

$ uname -r

So if you still have problems with an 14.04 just update to the lastes hardware enablement stack and it should just work.

Would have left just a comment but unfortunately you need reputation to leave one (i am puzzeled by this).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .