I am testing Ubuntu 14.04.2 LTS on Virtual Box. My ultimate goal is to build a real world RAID1 SAMBA home server. This is my first foray into a Linux distro. I have come a long way in the last 2 weeks though. I have a good understanding of root, users, groups, permissions, SAMBA shares, and mounts. Up until now, any trip ups I have had, I have been able to figure out with persistent "Googling" sites such as this one. This one has me stumped though.

Immediately after I installed mdadm, I was no longer able to boot up. Message repeats:

Incrementally starting RAID array   
mdadm: CREATE user root not found   
mdadm: CREATE group disk not found  
Incrementally started RAID array

I can get the GRUB menu and have tried recovery mode...same message

I have tried Boot-Repair-Disk both using default repair and the nodmraid option... same message after reboot.

I do not have RAID set up yet, I was hoping to do that with Webmin and mdadm.

This is frustrating! How can I fix it to boot again and how can I successfully install mdadm?

Update: I installed another Ubuntu along side the corrupted one and can now edit files in the original installation.

I have tried commenting out all entries of the mdadm.conf file. I have also removed the mdadm file and still cannot boot. Is there a way to remove the mdamd package from the corrupted installation?

Final Update: After not getting any answers to this question and spending endless hours trying to solve it, I went a head and re-installed. I knew all along that this was the easiest option, but I was really hoping to learn how to save a broken system. This time, I saved a snapshot right before installing mdadm. No matter how I installed it (GUI, CLI, "no-recommondations") same thing, system would not reboot. A little more research indicated that Ubuntu doesn't play well with mdadm. So I began looking for alternate distros. Currently I am playing with Xubuntu and liking it. And it breezed right through the mdadm installation no problem.

All that said... I would still like an answer to... "How could I have repaired the original installation without a full re-install?"

  • Xubuntu really is the same thing as Ubuntu for everything under the hood (everything unrelated to the desktop environment), so I don't think that changing the distribution derivative was the solution to this. Mar 24, 2015 at 0:16


You must log in to answer this question.

Browse other questions tagged .