2

My laptop is Thinkpas T400 with internal intel wifi link 5100 AGN. My wireless connection becomes lost after a while since every reboot. This happens both in my current 64-bit 14.04 and previous 32-bit 12.04. (In 14.04, sometimes my ethernet adapter also doesn't work.)

I found some dicussions by googling "intel wifi 5100 AGN Ubuntu", and they were trying different approaches without solving the issue.

I posted my dmesg output here for my wireless adapter wlan0 and its driver iwlwifi, and hope for some help.

$ dmesg | grep wlan0

[   22.680318] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   29.424514] wlan0: authenticate with 00:25:9c:1b:57:21
[   29.427265] wlan0: send auth to 00:25:9c:1b:57:21 (try 1/3)
[   29.429960] wlan0: authenticated
[   29.430048] iwlwifi 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
[   29.430051] iwlwifi 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
[   29.432078] wlan0: associate with 00:25:9c:1b:57:21 (try 1/3)
[   29.434535] wlan0: RX AssocResp from 00:25:9c:1b:57:21 (capab=0x411 status=0 aid=5)
[   29.437742] wlan0: associated
[   29.437771] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   30.444281] wlan0: deauthenticating from 00:25:9c:1b:57:21 by local choice (Reason: 2=PREV_AUTH_NOT_VALID)
[   30.446133] wlan0: authenticate with 00:25:9c:1b:57:21
[   30.446981] wlan0: send auth to 00:25:9c:1b:57:21 (try 1/3)
[   30.449875] wlan0: authenticated
[   30.450038] iwlwifi 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
[   30.450041] iwlwifi 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
[   30.452151] wlan0: associate with 00:25:9c:1b:57:21 (try 1/3)
[   30.454658] wlan0: RX AssocResp from 00:25:9c:1b:57:21 (capab=0x411 status=0 aid=5)
[   30.457904] wlan0: associated
[ 5120.374230] wlan0: deauthenticated from 00:25:9c:1b:57:21 (Reason: 7=CLASS3_FRAME_FROM_NONASSOC_STA)
[ 5123.676199] wlan0: authenticate with 00:25:9c:1b:57:21
[ 5123.677937] wlan0: send auth to 00:25:9c:1b:57:21 (try 1/3)
[ 5123.680496] wlan0: authenticated
[ 5123.680754] iwlwifi 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
[ 5123.680763] iwlwifi 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
[ 5123.684315] wlan0: associate with 00:25:9c:1b:57:21 (try 1/3)
[ 5123.688858] wlan0: RX AssocResp from 00:25:9c:1b:57:21 (capab=0x411 status=0 aid=5)
[ 5123.691922] wlan0: associated
[16757.341736] wlan0: deauthenticated from 00:25:9c:1b:57:21 (Reason: 7=CLASS3_FRAME_FROM_NONASSOC_STA)
[16757.380215] wlan0: authenticate with 00:25:9c:1b:57:21
[16757.386911] wlan0: send auth to 00:25:9c:1b:57:21 (try 1/3)
[16757.391132] wlan0: authenticated
[16757.391424] iwlwifi 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
[16757.391433] iwlwifi 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
[16757.392110] wlan0: associate with 00:25:9c:1b:57:21 (try 1/3)
[16757.395611] wlan0: RX AssocResp from 00:25:9c:1b:57:21 (capab=0x411 status=0 aid=2)
[16757.397671] wlan0: associated
[21321.548607] wlan0: deauthenticated from 00:25:9c:1b:57:21 (Reason: 7=CLASS3_FRAME_FROM_NONASSOC_STA)


$ dmesg | grep iwl 

[   13.916985] iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[   13.917156] iwlwifi 0000:03:00.0: irq 50 for MSI/MSI-X
[   13.959583] iwlwifi 0000:03:00.0: loaded firmware version 8.83.5.1 build 33692 op_mode iwldvm
[   14.475382] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
[   14.475386] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[   14.475387] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[   14.475389] iwlwifi 0000:03:00.0: Detected Intel(R) WiFi Link 5100 AGN, REV=0x54
[   14.475454] iwlwifi 0000:03:00.0: L1 Disabled - LTR Disabled
[   14.500372] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   22.554089] iwlwifi 0000:03:00.0: L1 Disabled - LTR Disabled
[   22.554494] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   22.651233] iwlwifi 0000:03:00.0: L1 Disabled - LTR Disabled
[   22.651625] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   29.430048] iwlwifi 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
[   29.430051] iwlwifi 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
[   30.450038] iwlwifi 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
[   30.450041] iwlwifi 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
[ 5123.680754] iwlwifi 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
[ 5123.680763] iwlwifi 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
[16757.391424] iwlwifi 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
[16757.391433] iwlwifi 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP

$ ifconfig

eth0      Link encap:Ethernet  HWaddr 00:24:7e:e0:62:50  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:20 Memory:fc600000-fc620000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:37304 errors:0 dropped:0 overruns:0 frame:0
          TX packets:37304 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:3623278 (3.6 MB)  TX bytes:3623278 (3.6 MB)

wlan0     Link encap:Ethernet  HWaddr 00:26:c6:3e:30:34  
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::226:c6ff:fe3e:3034/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:102840 errors:0 dropped:0 overruns:0 frame:0
          TX packets:96036 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:78001233 (78.0 MB)  TX bytes:16544959 (16.5 MB)


$ lshw -C network
WARNING: you should run this program as super-user.
  *-network               
       description: Ethernet interface
       product: 82567LM Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth0
       version: 03
       serial: 00:24:7e:e0:62:50
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k firmware=1.8-3 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:45 memory:fc600000-fc61ffff memory:fc625000-fc625fff ioport:1840(size=32)
  *-network
       description: Wireless interface
       product: PRO/Wireless 5100 AGN [Shiloh] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 00
       serial: 00:26:c6:3e:30:34
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.16.0-31-generic firmware=8.83.5.1 build 33692 ip=192.168.1.100 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:50 memory:f4200000-f4201fff
  • This kind of behaviour is already listed here askubuntu.com/questions/133770/… Hope this helps – UmaMaheshwar Reddy Mar 21 '15 at 4:44
  • Some Intel wireless cards are notoriously problematic, despite their supposed openness. Of the top of my head, Intel 4965 AGN, and Intel 5100 AGN come to mind. Those cards have not been working reliably for many years now, with Intel neither acknowledging the problem, nor able/willing to provide fixes. If the workarounds posted here and elsewhere do not help, there isn't much you can do. If possible, I'd recommend replacing the card. – mikewhatever Mar 21 '15 at 6:28
  • @mikewhatever: Is it replaceable and how? What card do you recommend? – Tim Mar 21 '15 at 10:51
  • Have you tried echo "options iwlwifi 11n_disable=8" | sudo tee -a /etc/modprobe.d/iwlwifi.conf then reboot? You might want to change the channel your wifi router is on as it might be causing problems and see if WMM can be enabled on the router – Jeremy31 Mar 21 '15 at 11:48
  • If you want to replace the Internal WiFi card, it's going to cause you a lot of headaches unless you can find the Service Manual for your Laptop (no experience with IBM: HP is pretty good at this) I have a Realtek WiFi A/B/G card and it just works... Otherwise buy something like the ThinkPenguin N150 and disable the one you have in your BIOS... – Fabby Mar 24 '15 at 21:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.