0

I am running a Windows 8.1 laptop. I used VirtualBox to create a virtual Windows 2008 server. I am trying to send a file to the laptop. It did not go. When I tried to ping the laptop, it did not work. When I tried to ping another laptop on the network it did not work. When I pinged the wireless router it worked. I then tried to ping the virtual box from the laptop it worked. Also, I am able to use a web browser to down load files from the virtual machine.

Any ideas why? It seems pings work in one direction, but not the other.

The network is running off of a wireless router.

  • Where is Ubuntu involved in this scenario? – steeldriver Mar 20 '15 at 23:57
  • @steeldriver From his question, it appears that Ubuntu is his Virtualbox host. He believes the Ubuntu host is the problem with the Windows guest connectivity. – L. D. James Mar 21 '15 at 0:09
1

Check Network Adapter page you've probably attached the 'Network Adapter' to 'NAT', the virtual machine will be on a different network so no ping unless you define a manual routing.

If you have no knowledge on networks, the easy way is to attach the 'Network Adapter' to 'Bridge Adapter' and bridge to the interface you're using for you local network in you case probably wlan0.

0

Quick answer. Some machines will have a firewall block (disable of ping response). By your description this appears to be the case. Some people disable ping (using a firewall) to prevent DOS attacks and unwanted scans of their computer. Disabling ping will not disable file transferring.

In order to transfer a file to a computer you have to have some type of network protocol setup where you can actually log into the computer with the provided network credentials for that particular machine.

Normally Windows network sharing is setup on the computer for allowing files to be transferred. You can look at Turn sharing on or off - Windows Help for enabling sharing on your windows machine.

Since it appears that you are trying to connect to a Windows machine from a Virtual machine run on a Linux host you can use the Windows host to scan and check if you have the network sharing services activated on the windows destination machine by running nmap. You could install it on the Linux host with:

$ sudo apt-get install nmap

Then you can scan your destination machine with:

$ sudo nmap -O 192.168.1.100 -oG -

Change the "192.168.1.1" to the IP of your destination computer.

After the scan completes look for something that resembles:

# Nmap 6.46 scan initiated Fri Mar 20 19:58:28 2015 as: nmap -O -oG - 192.168.23.102
Host: 192.168.1.100 () Status: Up
Host: 192.168.1.100 () Ports: 135/open/tcp//msrpc///, 139/open/tcp//netbios-ssn///, 445/open/tcp//microsoft-ds///, 554/open/tcp//rtsp///, 2869/ope
# Nmap done at Fri Mar 20 19:59:38 2015 -- 1 IP address (1 host up) scanned in 70.26 seconds

This is showing that microsoft's network (139/open/tcp//netbios-snn) is active on this IP.

  • Thank you for the responses. However, they do not completely address the issue. I am using a laptop with Windows 8. The vm is running Windows Server 2008. I am able to download a file from the vm to the laptop using a web browser. I cannot ping from the vm to the laptop. Most of the time I can ping from the laptop to the vm. The network setting is set to bridging, and is using the wireless adapter that the laptop is using to connect to the network. I can also browse the internet from the vm. I will check to see if there is a firewall on the vm or laptop that could be blocking. – Richjj Mar 22 '15 at 21:47
  • Thanks for the info from all of you. It looks like the issues was with a McAfee firewall that was blocking some traffic. Mostly icmp. Thanks again! – Richjj Mar 22 '15 at 22:59
  • You may notice that is the first item in my answer. Since it works you might consider giving back to the community by marking this issue as solved. This way others with a similar problem can easier find the resolution. Look at the first paragraph quick answer. Glad it worked! – L. D. James Mar 22 '15 at 23:53
  • Sorry, new to the community. – Richjj Mar 24 '15 at 17:50
  • Is there a trick. I do not see a button for marking it as solved, answered, etc. For those checking, it is solved. Thank you for all of the responses advice. – Richjj Mar 24 '15 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.