0

This question already has an answer here:

I am on Ubuntu 14.04. I want to install two packages: pantheon-shell and elementary-tweaks but getting following error:

$ sudo apt-get install pantheon-shell
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pantheon-shell : Depends: slingshot-launcher but it is not going to be installed
              Recommends: gala but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install elementary-tweaks
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 elementary-tweaks : Depends: gala but it is not going to be installed
                 Depends: slingshot-launcher but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried this, didnt help:

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

marked as duplicate by karel, Eric Carvalho, David Foerster, LnxSlck, Charles Green Apr 7 '18 at 14:12

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Might want to mention what ppa you're using. – doug Mar 20 '15 at 22:55
  • @doug I am using sudo apt-add-repository -y ppa:elementary-os/testing, sudo apt-add-repository -y ppa:versable/elementary-tweaks-isis and sudo apt-add-repository -y ppa:elementary-os/daily. btw i just installed pantheon DE – Edward Torvalds Mar 20 '15 at 23:02
0

Try the following, in the shown order

sudo apt-get autoclean && apt-get clean
sudo aptitude update && sudo aptitude -y upgrade
sudo aptitude install <package>
  • it did not help – Edward Torvalds Mar 20 '15 at 22:54
  • it says there is nothing like clear – Edward Torvalds Mar 20 '15 at 23:04
  • can you post your sources.list please, this might help – s1mmel Mar 20 '15 at 23:05
  • I corrected it, autoclean removes old unused packages and clean removes the "main" cache. – s1mmel Mar 20 '15 at 23:09
  • copy of sources.list here – Edward Torvalds Mar 20 '15 at 23:11
0

I guess the repos have the same packages but with different versions?

I think you need APT Pinning for that, to tell apt which repo you prefer to install from.

ppa:elementary-os/testing
ppa:elementary-os/daily

This might be your problem. You need to give these repos prio's.

Not the answer you're looking for? Browse other questions tagged or ask your own question.