1

When trying to open Ubuntu Software center getting this:

This error could be caused by required additional software packages which are
missing or not installable. Furthermore there could be a conflict between software
packages which are not allowed to be installed at the same time.

When trying to execute: sudo apt-get -f install getting this:

Reading package lists... Done                                                  
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 leap : Depends: libgl1-mesa-glx (>= 7.7.1) or
                 libgl1-mesa-glx-lts-precise (>= 7.7.1) but it is not installable or
                 libgl1-mesa-glx-lts-quantal (>= 7.7.1) but it is not installed or
                 libgl1-mesa-glx-lts-raring (>= 7.7.1) but it is not installed or
                 libgl1-mesa-glx-lts-saucy (>= 7.7.1) but it is not installed or
                 libgl1-mesa-glx-lts-trusty (>= 7.7.1) but it is not installed
E: Unmet dependencies. Try using -f.

Can someone help me with this?

  • Did you tried sudo apt-get -f install as it said? – Helio Mar 20 '15 at 20:50
  • it's the answer, when I try to do it – Jokhongir Mamarasulov Mar 20 '15 at 21:16
0

Good Luck!

  1. sudo dpkg --configure -a
  2. sudo apt-get -f install
  3. sudo dpkg --configure -a
  4. sudo apt-get update
0

Try sudo dpkg --purge --force-all leap

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.