3

After recently doing something that involved installing rvm, this error occurs when I try using lolcat.

/home/max/.rvm/rubies/ruby-
2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require': 
cannot load such file -- lolcat/version (LoadError)     from
/home/max/.rvm/rubies/ruby-
2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'  
from /usr/games/lolcat:21:in `<main>'

It seems I can get lolcat working again by doing gem install lolcat but i think that just installs another copy of lolcat rather than fixing the existing one. Can someone tell me what the original issue is? Also, what's the difference between the lolcat installed from gem and the lolcat installed from apt-get?

3

because lolcat is a part of ruby, by default before you install rvm, your system use the system ruby. first, remove lolcat

sudo apt-get purge lolcat -y

then install it again by:

gem install lolcat

this working for me!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.