Moved to ubuntu 14.04 not so long ago. I had Logitech f510 and f710 while using windows, but I was not able to make them work on my ubuntu system. What was done - installed xboxdrv. After it installed qjoypad and jstest-gtk but they are not able to see my gamepads. Tried Logitech Rumble Gamepad F510 and How do I configure a joystick or gamepad? with no luck. And find out that actually my problem is that device is not listed in /dev/input and I'm not sure what to do to move it there.

Here is dmesg output:

[ 2014.619530] usb 3-2: new full-speed USB device number 7 using xhci_hcd
[ 2014.639445] usb 3-2: New USB device found, idVendor=046d, idProduct=c21e
[ 2014.639450] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2014.639454] usb 3-2: Product: Rumble Gamepad F510
[ 2014.639456] usb 3-2: Manufacturer: Logitech
[ 2014.639459] usb 3-2: SerialNumber: B289B4F3


Bus 003 Device 007: ID 046d:c21e Logitech, Inc. F510 Gamepad [XInput Mode]

With the evtest I can't see device listed and there are no js* files in /dev/input.

Will be glad for any advice. Thanks.


I fixed it reinstalling ubuntu. No idea what happened.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.