This question already has an answer here:

How do I install ubuntu packages from the ubuntu cd. I have ubuntu-desktop 10.04 running and I have to install wvdial package but no internet connection for installing from apt repository.

marked as duplicate by Eric Carvalho, Pilot6, Warren Hill, karel, Maythux Jul 22 '15 at 8:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Since wvdial is on the installation CD, you can enable System -> Administration -> Software Sources -> Ubuntu Software -> Installable from CD-ROM/DVD -> Cdrom with Ubuntu 10.04 and then install it via Synaptic.

In the long run, though, you should have a way to install software upgrades and packages that aren't included on the CD. For this I recommend using Keryx, which is essentially a relay for your package manager over a USB drive. Updates can be downloaded using an internet-connected computer running Windows, OS X, or Linux.

  • Isn't there any option to install from command line as Software Sorces could not add the cd-rom. – user3215 Oct 13 '10 at 1:26

This should help:






  • I think I can't try this as this require internet – user3215 Oct 13 '10 at 1:27

Using System -> Administration -> Software Sources (or Settings -> Edit Origins in KPackageKit), go to Other Software tab and click "Add CD-ROM" while the CD is in the drive. Choose to reload the software sources, and then install as usual. It'll use the CD as a repository.

  • When i click "Add CD-ROM" it prompts to insert cd. The cd is inserted and no problem with the cd drive and the cd is mounted on the desktop automatically. Don't know what's the problem. – user3215 Oct 13 '10 at 1:23
  • I think it's getting dependency error – user3215 Jan 5 '11 at 16:34

It is not dependency error. The apt is not recognizing it.

Try to see where the cdrom mounts, by entering command mount in the terminal. It probably mounts on /media/cdrom but apt recognizes cdrom in the /media/apt directory. so make a symbolic link

sudo ln -s /media/cdrom /media/apt. After that you can enter this command,
sudo apt-cdrom add, it will work.

Not the answer you're looking for? Browse other questions tagged or ask your own question.