3

rebooting today I notices I have lost my sound device over night:

sudo aplay -l

aplay: device_list:268: no soundcards found...


lspci -v | grep -A7 -i audio

00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
Subsystem: Intel Corporation Device 7270
Flags: bus master, fast devsel, latency 0, IRQ 10
Memory at e0730000 (64-bit, non-prefetchable) [size=16K]
Capabilities: < access denied >

00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0

No Kernel driver in use and Kernel modules. I'd reckon that is not good.
Thought I need to have kernal module snd-hda-intel running.

locate locate snd-hda-intel

/lib/modules/3.13.0-37-generic/updates/kernel/snd-hda-intel.ko
/var/lib/dkms/oem-audio-hda-daily/original_module/3.13.0-37-generic/amd64/snd-hda-intel.ko

Any tip how to sort this?

Many thanks
Yanoidis

BTW
As you can probably see above, I have PPA Ubuntu-audio-dev/alsa-daily enabeled

0

I had the same problem and tried a lot of things such as reloading Alsa and even reinstalling it nothing helped. I updated to the 3.16 kernel version. I used this command to update the kernel on 14.04 sudo apt-get install linux-image-generic-lts-utopic

0

Try force reloading Alsa. To do that, use the following command in terminalCtrl+Alt+T

sudo alsa force-reload

After force reload it may seemed to be like hanged or still in process .. No need to get panic. It may take some couple of seconds. You can simply close it afterwards by using Ctrl^C

Now, you need to reboot your computer..

  • 1
    Thanks for the swift reply! I tried that. Didn't change anything. – yanoidis Mar 19 '15 at 21:00
  • Solved the problem: upgraded from kernel 3.13.0-37-generic to 3.16.0-31-generic – yanoidis Mar 20 '15 at 20:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.