I have a dual boot system with Windows 8 and Ubuntu 14.04LTS and I have a ASUS Xonar DGX. There's no sound in Ubuntu but it works correctly in Windows. I've looked at some of the other threads and used the terminal to check the card out. (That was a fun learning experience. :) ) The card appears to be recognized correctly. It shows as a CMI8788 [Oxygen HD Audio] in the sound settings as it should. But when I test the sound I get nothing.

Any help would be greatly appreciated.

EDIT: I ran the requested reset on alsa and ran Lspci -v | grep -A7 -i "audio" again

01:00.1 Audio device: NVIDIA Corporation GF104 High Definition Audio Controller (rev a1)
    Subsystem: NVIDIA Corporation Device 0865
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at f7dfc000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel

02:00.0 SATA controller: JMicron Technology Corp. JMB363 SATA/IDE Controller (rev 03) (prog-if 01 [AHCI 1.0])
04:04.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]
    Subsystem: ASUSTeK Computer Inc. Device 8521
    Flags: bus master, medium devsel, latency 64, IRQ 17
    I/O ports at d800 [size=256]
    Capabilities: <access denied>
    Kernel driver in use: snd_oxygen

07:03.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev c0) (prog-if 10 [OHCI])
  • run sudo alsa force-reload from terminal and check again. Mar 19, 2015 at 15:34
  • Is the <access denied> tag the problem? Mar 19, 2015 at 17:20
  • It just means that lspci could not read some information because it was not run as root. Anyway, did you tell Ubuntu that you want to use the DGX, and not the GPU's HDMI output?
    – CL.
    Mar 19, 2015 at 22:58
  • I did. It's set up to run the CMI8788 audio out. The other is actually disabled in the BIOS, I'm not sure why it still shows up. Mar 23, 2015 at 13:47

4 Answers 4


Just ran into the same problem

After fiddling around I started alsamixer, selected the sound card (F6), and changed Analog Output to Multichannel.

  1. Install alsa-utils In terminal type:

    sudo apt-get install alsa-utils
  2. Run alsamixer in terminal

  3. Hit the F6 key.

  4. Arrow over to "Analog Output" and arrow up/down to change to "Multichannel"

enter image description here

  • I had actually given up on it since I only use the ubuntu side to build ROMs for my phone. It's not like I hang out when it's doing that. But I just tried this today and it fixed it! Thanks man. Jan 27, 2016 at 12:48
  • Thanks for this, this is exactly what I needed to do! I was just about to uninstall the ALSA/PulseAudio packages and recompile from source too, because I thought I was doing something wrong... PulseAudio still reports the output port as being Headphone, so I guess alsamixer is the way to go - I didn't know about this tool before to be honest, but am looking forward to learning how to use it. Apr 15, 2016 at 21:14
  • good trick helped me as well
    – JoKeR
    Oct 20, 2017 at 12:40
  • The problem occured in my case when I installed Ubuntu 18.04 (the card worked normally with the 16.04 version). I knew that the card being listed in the sound devices, the solution had to be simple. Thanks for the very clear explanations. Jan 3, 2020 at 9:49

Hey all I just got a Xonar card working in my Ryzen 3 1300X Linux Mint 18.2 box. Mint is a fork of Ubuntu. This post/question is old but I thought I would mention that I used alsamixer as well. Multichannel works but I found that while the sound option in the control panel would show Headphones it was not specifying front panel audio or the port on the sound card. Alsamixer gave me "Stereo Headphones" and "Stereo Headphones FP". As soon as I selected "Stereo Headphones" it worked and sounds great! Hope this little update helps someone. Cheers.


type in console alsamixer, choose your device by f6(if you can't see your card-device it not inserted) and go to 'Analog aut' by 'right-arrow', change the value by 'up arrow', press f10 to save. Maybe you should make appropriate analog output with sound settings on your ubuntu. I find my combination and it works.


You need to edit this file /etc/modprobe.d/alsa-base.conf and then add a line in its end. Use the following commands:

sudo nano /etc/modprobe.d/alsa-base.conf

Now add the following line at its end:

options snd-hda-intel model=generic

Now reboot your computer. It should solve your problem.

See this question:

No sound from speakers, but headphones work

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .