The laptop has Ubuntu 14.04, it shows neighbors networks and it was working fine before. My phone and desktop connect to my home Wi-Fi with no problems. This has happened a few times before but in an hour or so I can resolve the problem by rebooting. It has been almost a day and it didn't fix itself.

I have tried:

sudo apt-get purge bcmwl-kernel-source
sudo modprobe -rv wl
sudo modprobe -v brcmsmac

sudo service networking restart
sudo service network-manager restart

ifconfig wlan0 down
ifconfig wlan0 up


iwconfig wlan0 txpower off
iwconfig wlan0 txpower auto

I rebooted after those were executed but it did nothing.

  • 1
    If you issue sudo iwlist scan does your network show up? You might want to grep for your network depending on how many surrounding networks there are, there may be a lot of output. – Dylan Mar 18 '15 at 23:28
  • nope, it doesn't show up there – viale Mar 18 '15 at 23:52
  • 2
    switching the wireless channel fixed it – viale Mar 19 '15 at 0:26
  • Voting to close. Fixed as per comment by OP. – belacqua Mar 19 '15 at 2:10
  • Go to your network settings, change the security to WPA or WPA2 for that particular network. If that still fails, try getting an update. This would be a software issue that is likely on your system. – vembutech Mar 19 '15 at 20:42

The OP answered the question themselves in a comment:

switching the wireless channel fixed it - viale



nmcli dev wifi

a simple, clean and elegant way to get what you need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.