1

my first question, please be gentle ;)

I'm trying to access a smb share at my work using kubuntu 14.10 (Kernel 3.16.0-31-generic). Dolphin can access the share if I type in the smb://ip/share in the address line, but

sudo mount //ip/share /media/share -o username=user,password=password,workgroup=workgroup

gives me a

mount error(5): Input/output error
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

To get the smb call in dolphin to work, I added the correct workgroup in smb.conf. I also added my username and password in system settings-> network -> sharing Does anyone have any suggestions for me?

Calling my admin didn't help. They are completely windows based and are not allowed to help with linux based problems.

edit

As suggested, after running

sudo mount -t cifs //ip/share /media/share --verbose -o user=user,domain=workgroup,pass=password

I get the following statement

mount.cifs kernel mount options:  
ip=xxx.xxx.xxx.xxx,unc=\\xxx.xxx.xxx.xxx\share,user=user,,domain=workgroup,pass=********
mount error(5): Input/output error
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

can anyone make anything out of this?

  • Try running: mount -t cifs //ip/share /media/share --verbose -o user=user,password=password,domain=workgroup and see what the error may be. – MSumulong Mar 18 '15 at 16:03
3

The problem was fixed, when I added the sec=ntlm option

  • 2
    You need to specify where you added sec=ntlm-- in your smb.conf? as a command line argument to Dolphin? Be specific. – erapert Jul 11 '17 at 2:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.