So when I use: sudo airodump-ng -c 6 --bssid #### -w wepdump -i mon0

I don't see any packets generating as it runs, BSSID, Station, PWR, Rate, Lost, Packets and Probes stay blank. I use Intel PRO/Wireless 3945ABG but I'm confused because as I read through various sources, some say the patch needed for the chipset is not needed anymore and when I try to patch it regardless, I get errors. Yes I use this for educational purposes with my own WEP connection. Please help!

EDIT: Going through this channel problem like mine (I think?) to figure out what's going wrong.


You'll have to generate traffic by performing an ARP-request packet injection, using aireplay-ng.

You'll need to use an authenticated client's MAC Address in the following commands in order to make them work, otherwise the injected packets are going to be ignored by the access point.

First perform a fake-authentication on the target access point: with airodump-ng running in the background, open another Terminal with Ctrl+Alt+t and run:

aireplay-ng -1 0 -e <SSID_name> -a <access_point_MAC_address> -h <associated_client_MAC_address> mon0

Then, open another Terminal and run:

aireplay-ng -3 -b <access_point_MAC_address> -h <associated_client_MAC_address> mon0
  • Awesome however I got "mon0 is on channel 7 but the AP uses channel 6" I'll use the code boxes for these posts next time I swear! – Waypoint Mar 18 '15 at 6:06
  • @Waypoint You have to set your interface to use the same channel of your access point, i.e. to start airmon-ng with airmon-ng start mon0 6 – kos Mar 18 '15 at 6:14
  • So I did your suggestion this time with the correct ch and got the Authentication success indicating I don't have mac filtering enabled. Now I'm trying ` sudo aireplay-ng -3 -b <AP MAC> -h MY:MA:CA:DD:RE:SS <interface>` but nothing happened, just "aireplay-ng --help for help" airodump-ng was running with no packets generating. – Waypoint Mar 18 '15 at 6:26
  • @Waypoint The command is aireplay-ng -1 0 -e <SSID_name> -a <access_point_MAC_address> -h <associated_client_MAC_address> mon0, and you'll need to use an authenticated MAC address in order to make it work, otherwise the access point will only generate useless DeAuthentication packets – kos Mar 18 '15 at 6:29
  • @Waypoint Sorry I misread. aireplay-ng -3 -b <access_point_MAC_address> -h <associated_client_MAC_address> mon0 is what you need, so you need to find the MAC address of a client associated to the access point in order to run this command as well – kos Mar 18 '15 at 6:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.