I'm trying to install Ubuntu Server 14.04.2 on an old Athlon 64, but as soon as I get past the initial menu, choosing to install Ubuntu Server, I get some console output and everything gets stuck on:

mount: mounting /dev/sda on /media failed: Invalid argument
umount: can't umount /media: Invalid argument
mount: mounting /dev/sdb on /media failed: Invalid argument
umount: can't umount /media: Invalid argument

I used the exact same USB stick to install on another box. I couldn't find anything else about this error other than this topic, where one user claims it eventually works, but in my case I left it sitting there for almost an hour and nothing.


9 Answers 9


I found some brutal but effective method :-) When I reach that error I simply pulled out the USB stick wait for about 10 seconds and push it in again. Waiting for another 10 seconds, enough to be mounted. After that, I choose to retry the CDROM search and... voila, the installation goes on. Once again, it is brutal and can damage your USB stick, but it worked for me.

  • Would be nice to know why this works, it's really crude...
    – pzkpfw
    Jan 4, 2016 at 13:22
  • this absolutely works for me Jan 29, 2016 at 20:04

So, after some time the installation resumed, but it fails on the next step, trying to mount a cdrom, which doesn't exist since I'm booting from USB. I skipped that step and manually created a link from /media at /cdrom and it works.

  • And how did you create the link from media to cdrom?
    – KhoPhi
    Apr 27, 2018 at 22:20

I was just encountering this problem, and I think the solution is that I had disconnected my floppy drive. I plugged it back and, and it while it displayed errors trying to mount the hard drive partitions (which makes sense, as they don't have filesystems on them) it seemed to get past this point successfully.


Was having the same problems as you had Pedro. The error messages about the failed mounting would at first not disappear. After a reboot the installation would continue after 5 minutes or so of error messages about the failed booting.

Then the message about the CD which could not be found appeared. One way to solve this is just like you to manually create a link. Because I have 3 internal disks my USB was the sdd. By typing the following command in the kernel during setup it worked:

mount -t auto /dev/sdd1 /cdrom

Then after the installation would stop at the package manager for some reason.

The final solution was in the software used to make an image on the USB device. I used rufus. After I switched to Win32Diskimager all the errors where gone and the installation is now successful. Hope this helps.

  • Yes Rufus was my problem as well! Switching tools used to make the bootable sub fixed it for me too. Nov 6, 2015 at 4:16

Best would be disable any floppy diskette, any slave or other IDE devices from BIOS settings. Only enable the peripheral device setting and reboot the computer. It should be able to mount properly from the target location. Its easy and works for me .. :)


To add my two cents - got stuck with this error. Using Ctrl-Alt-F (1-7) did nothing, but Ctrl-C brought me back to the graphical installer and I was able to start a console. We are using a CDROM, so I did mkdir /media/cdrom to create the standard mountpoint then mount -t auto /dev/sda1 /media/cdrom. Used exit to get back to the graphical installer and then selected choose language to continue the installation. It's taking a while on package installation (using Alt-F2 shows the console, where we can see that the delay seems to be due to it searching for floppy disks -- guess I should have disabled the floppy in the BIOS)


i confirm it is a problem in BIOS. Disable floppy disk in the BIOS (hardware) and also disable in the boot device. And it will works!

  • Prepare usb drive by startup disk creator
  • Copy ubuntu-xxx.iso to / of usb drive
  • Start the installation as usual
  • When you see "Retry mounting the CD-ROM" Select No, then Continue.
  • Alt + F2
  • mount -t iso9660 -o loop /media/ubuntu-xxx.iso /cdrom
  • Alt + F1
  • Select "Detect and mount CD-ROM" That's it...

As workaround in my case I found that I can mount USB flash drive partition as /cdrom and setup will continue:

  1. When installer report "Try mounting the CD-ROM?" select "", then "".
  2. Then in "[?] Ubuntu installer main menu" select "Execute shell", then "".
  3. Mount flash drive partition as /cdrom, in my case it was /dev/sda1:

mount /dev/sda1 /cdrom

  1. Exit shell by entering


  1. Select "Detect and mount CD-ROM" in appeared "[?] Ubuntu installer main menu" --- installation will continue.

Please don't use ALT + F2 because it won't let you mount the disk but you can try both see if it works out for you.

Source : https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/778319/comments/4

Not the answer you're looking for? Browse other questions tagged .