0

I have this issue with my number pad, that when I press the / instead of giving me the expected /, it gives a . Note that the unwanted slash is slightly more tilted than the expected one. Also, * gives ⋅, and - gives−. The + seems to work fine.

Using this website, I can determine that the faulty keys do give different values than expected.

∕ : Division Slash (Solidus)
⋅ : Dot Operator (Asterisk)
− : Minus Sign (Hyphen-Minus)

I put the wanted character in brackets. It seems that my numpad is in some kind of math mode. I don't want to remap the keys to the wanted value, I instead want to fix the problem, this should be possible, as the problem first occurred a while ago while typing math equations in gedit.

EDIT: The same thing happens with the . button on the numpad giving , instead of the expected .

I am using Ubuntu Gnome 14.04 LTS, with a Dell SK-8115 keyboard.

If I go to my system settings, my keyboard layout is English (US). If I view the layout I see this:enter image description here If you look on the numpad's period key, it shows a , above the Del text, instead of the wanted period. For the other key, it shows multiple values, e.g. the / shows two slashes, and a division symbol.

0

I found a solution!

If I ran dconf-editor in the terminal, nagivated to org.gnome.desktop.input-sources, this window would show up:

The xkb-options had some values in it, after clicking Set to Default, the values were deleted, and my buttons were restored to what I wanted them to do.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.