4

I'm running Ubuntu 14.04 desktop on my laptop. After the screen goes to sleep, on resume I get a second mouse pointer stuck in the middle of the screen. This happens whether or not I have a USB mouse connected. Other similar threads indicate that there's something that can be done with xinput to make the second mouse pointer go away, but so far I haven't been able to figure out what that is. Output of xinput --list:

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=12   [slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft Trackball Optical®    id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]

2 Answers 2

6

This got rid of it for me and stopped the cursor from flickering too:

Do System Settings > Displays

And turn-off / disable Unknown Display.

1
  • 1
    Thanks! This led me to the realization that I've got an nvidia optimus setup on this laptop, and installing the correct nvidia driver seems to have fixed it. That was where the phantom "Unknown Display" was coming from on this machine. Apr 18, 2015 at 1:48
1

I am running 20.04 LTS on a desktop PC and encountered this issue. What fixed it for me was toggling the Displays Refresh Rate from 60.00 Hz to 59.94 Hz. The problem remained fixed (i.e., no stuck second mouse pointer) even when I then changed the Refresh Rate back to 60.00 Hz.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .