2

I don't like to post questions but I've spent hours searching and am in dire need of help! I'm trying to run Ubuntu 14.04 headless and remotely login via VNC from Windows. I've read many posts that the way to go is to install xserver-xorg-video-dummy and this is where I'm stuck

root@mediaserver:~# apt-get install xserver-xorg-video-dummy
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-video-dummy : Depends: xorg-video-abi-15
                            Depends: xserver-xorg-core (>= 2:1.14.99.902)
E: Unable to correct problems, you have held broken packages.

root@mediaserver:~#
root@mediaserver:~#
root@mediaserver:~#
root@mediaserver:~# apt-get install xorg-video-abi-15
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'xserver-xorg-core' instead of 'xorg-video-abi-15'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
root@mediaserver:~#

Looks like libcheese is the culprit. I get the same output if I try to install xserver-xorg-core. From the above, looks like I need >= 3.4, however, mine is at 3.10

root@mediaserver:~# dpkg -s libcheese-gtk23
Package: libcheese-gtk23
Status: install ok installed
...
Version: 3.10.2-0ubuntu2

When I try to upgrade it, I get this:

root@mediaserver:~# apt-get upgrade libcheese-gtk23
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
libcheese-gtk23 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Is this a problem with my repository??? I have UN-commented all of them. Am I missing a special repository that wouldn't be included in 14.04?

Please help!!! Thank you in advance

root@mediaserver:~# uname -a Linux mediaserver 3.16.0-31-generic #41~14.04.1-Ubuntu SMP Wed Feb 11 19:30:43 UTC 2015 i686 i686 i686 GNU/Linux

3

This is a dependency problem in package manager like this problem

I tried aptitude and the proposed solutions destroyed the entire ubuntu installation...

You need to install some other packages before installing dummy driver Try this and it will resolve the problem:

apt-get install  libglew-dev libcheese7 libcheese-gtk23 libclutter-gst-2.0-0 libcogl15 libclutter-gtk-1.0-0 libclutter-1.0-0  xserver-xorg-input-all

P.S. I tried the above packages on ubuntu desktop x64 14.04.3 and 14.04.4 and worked for both.

2

The driver is being replaced. Run apt-cache search video-dummy

xserver-xorg-video-dummy-lts-quantal - Transitional package for xserver-xorg-video-dummy

xserver-xorg-video-dummy-lts-raring - Transitional package for xserver-xorg-video-dummy

xserver-xorg-video-dummy-lts-saucy - Transitional package for xserver-xorg-video-dummy

xserver-xorg-video-dummy-lts-trusty - Transitional package for xserver-xorg-video-dummy

xserver-xorg-video-dummy-lts-utopic - X.Org X server -- dummy display driver

  • I've got the same problem, but don't understand the answer. I use 14.04 LTS. What am I supposed to install - xserver-xorg-video-dummy-lts-trusty? Didn't help, what is a transitional package? – nmw01223 Mar 28 '16 at 17:40
  • 1
    I do not know if was resolved or not but I have met the same problem and the soultion is to install the "xserver-xorg-video-dummy-lts-trusty" package since you are running 14.04 LTS. – Surya Teja Karra Apr 23 '16 at 3:23
  • I did not understand the answer either. @Bill - I would love to upvote this answer but please add the remarks on which package to install. Thanks! – divB Apr 27 '16 at 23:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.