0

When I first installed Ubuntu more then year ago, I also installed Shockwave Flash plugin and its automatic updater.
Then I learned (as many newbies did) that Adobe does not updating it after version 11.2. So I switched to alternative players.
Video playing was fine, but I could not run some on-line games that needed newer Shockwave Flash. I also tried Chrome for these games, it started but got stuck in the middle.
I did not removed Shockwave plugin, just disabled it and got it out of my mind,

...until the middle of January, when Shockwave updater suddenly notified me about a new critical security update.
So I installed Pepperflash which gave me version 16.0 which is now updated to version 17.0, as recommended by Adobe Security Bulletin.

About week later with another update I looked at the Adobe Security Bulletin again. Now it was recommending version 11.2 for Linux.

Maybe they were so hurry to fix the critical problem that forgot about not updating Linux version, but then fixed it, I do not know.

Since then everything working, including games.
The version 11.2 was not removed.
Now I have 2 Shockwave plugins, and they keep updating. Version 16.0 recently updated to 17.0.0.134, and another one to 11.2.202.451.
I prepared a screenshot to post here, but I do not have enough reputation to post images.
I disable version 11.2, but sometimes it get enabled by itself. I suspect updates do it.
Official Adobe page suggests version 11.2 for Linux, as before.

My questions are:

  • Is it safe to use?
  • If yes, maybe it is good idea to copy recent Linux Shockwave flash from my computer and spread in the world? I need instructions how to do it for Ubuntu 14.04.
  • If it is not safe, what about using it just for some games sites?
  • Should I remove version 11.2?

UPD1:
I am sorry I did not explained it well. I have Firefox running on Ubuntu, and it has 2 plugins named Shockwave Flash:

  1. Shockwave FlashShockwave Flash 17.0 r0
  2. Shockwave FlashShockwave Flash 11.2 r202.

It was copy/paste from FF add-ons page.

Upd2:
I did more research. Well, I was so wrong!
The file of "Shockwave FlashShockwave Flash 17.0 r0" is libfreshwrapper-pepperflash.so.
So I do have PepperFlash and Adobe Flash.

$ dpkg --get-selections | grep flash
adobe-flash-properties-gtk          install
adobe-flashplugin               install
flashplugin-installer               deinstall
pepperflashplugin-nonfree           install

They probably updated at the same day, so I thought both plugins are from Adobe. It must be the PepperFlash that make the games to work.
To add more confusion, Firefox plugin page calls it "Adobe Flash Player Shockwave Flash 17.0 r0".

The only question that remains is:

  • Do I need both Shockwave Flashes?
1

As far as I can tell, the latest version for Linux available at this moment is Version: 11.2.202.451 (I obtained this information from the about:plugins page in Firefox and verified at https://get.adobe.com/flashplayer/ ).

It's entirely feasible that the update recommendations are based on the erroneous assumption that everyone is running a copy of Windows (which IMHO has more security holes than swiss cheese).

I'm running the version stated above and haven't had any issues. I do not recommend removing it. It doesn't appear as if Adobe feels the need to update the version available for Linux (although they are still providing security back-ports AFAIK)

Since both plugins are listed in firefox it seems to be handling them fine seperately. I don't think you are losing anything by leaving them as is. Be that as it may, if you do decide to remove one of them and later discover that you need it it worst you'll have to do is reinstall firefox and a plugin or at best a plugin. As I recall flashplugin-installer is what's responsible for putting 11.2 on your system. I can't speak to your safety concerns as AFAIK either way your looking at closed source. You can choose to trust Adobe or Google, the choice is yours. It's interesting to me that firefox picked up the extension as it supposedly only works for Chromium or Chrome) according to this.

Source(other platform availability): https://get.adobe.com/flashplayer/otherversions/

  • So you saying Linux users would not be interested in running most recent Shockwave Flash version on Linux FF even if such a possibility exists. I understand. – user244413 Mar 17 '15 at 17:06
  • @user244413 No, that's not what I said. Please edit your question if you didn't mean to ask about version 16 and re-read my answer if you did. – Elder Geek Mar 19 '15 at 12:15
  • It was wrong question, I edited it. But I think it is interesting discovery that PepperFlash presented in Firefox as a Shockwave Flash. – user244413 Mar 19 '15 at 16:32
  • @user244413: I gathered that PepperFlash is only Chrome's "wrap" of the official adobe flash available for Windows, so it really is still Shockwave Flash. – sipral Mar 27 '15 at 13:10
  • Related: askubuntu.com/questions/562271/… – Elder Geek Mar 27 '15 at 13:47
0

It seems to be possible due to this project: https://github.com/i-rinat/freshplayerplugin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.