3

I figured even before reading http://plugable.com/2014/03/06/displaylink-usb-2-0-graphics-adapters-on-linux-2014-edition that DisplayLink won't work with proprietary nVidia driver. I also see that the USB monitor (and AOC) is activated while the machine is booting. As soon as the proprietary driver kicks in, it blanks out.

If I enable nouveau driver and reboot the machine, only the USB monitor shows the graphical display, and my notebook's monitor remains blank. When I look into Unity's standard "Displays" settings, only the AOC monitor is detected. (When I run proprietary nVidia driver, only the Built-in Display is detected). The color depth is very low though, but I wouldn't mind that too much as a secondary monitor. I know it's not for gaming or video.

Could anyone help with this? I'm running latest stock kernel of 64bit ubuntu: uname -a: Linux erebus 3.13.0-46-generic #79-Ubuntu SMP Tue Mar 10 20:06:50 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I can provide any other logs if needed, but I don't want to unnecessary clutter this post in advance. I hope someone else already got it working with this combination: Ubuntu 14.04 64 bit, nVidia GPU and DisplayLink monitor.

  • Extra information: I have an SLI config, so two graphics cards. Is nvidia-prime take part in any way when a DisplayLink monitor is used? Can the SLI config an extra situation in my case which is a problem? – Csaba Toth Mar 17 '15 at 0:27
  • Now DisplayLink provides an Ubuntu kernel driver. I haven't had luck with it yet. displaylink.com/downloads/ubuntu – Csaba Toth Mar 5 '16 at 6:07
  • Lately I used Ubuntu Studio (Xfce4) 15.04 and then 15.10. I bought a GeChic On-Lap a while ago. Very pricey, but has HDMI input. – Csaba Toth Mar 5 '16 at 6:09
  • Also states here support.displaylink.com/knowledgebase/articles/… that closed source nvidia drivers are not supported – Karl Morrison Sep 14 '16 at 8:57
  • i would suggest unplugging the sli for now to remove complexity , then when you have linux setup with a single card renable it. I would recommend completely removing the second card not just unplugging the link. – Amias Jan 5 '17 at 11:21
4

I got this to work on my Laptop with Intel Graphics + Nvidia 870M by switching the GPU from Nvidia to Intel using Nvidia X Server Settings. I'm using the Nvidia proprietary driver 352.xx and the latest displaylink linux drivers from displaylink's website.

  • I'd even go that way, but my laptop (Clevo P570WM) has desktop CPU in it and the i7-4820K doesn't have integrated graphics :(. Your solution seems like working for some people though. I''l give another try to the DisplayLink Linux driver if I have time... – Csaba Toth Apr 26 '16 at 22:11
  • Unfortunately it tells me I have to log out to apply the changes, which makes it of little use for me (may as well just not use nvidia). – James Hirschorn Oct 25 '16 at 19:42
  • My newest laptop has mobile CPU in it but there's no BIOS switch to enable the integrated graphics. I haven't tried any optimus switcher either. – Csaba Toth Oct 25 '16 at 21:27
1

Check what kind of DisplayLink monitor you have. In my case an AOC e2251fw, and it turned out that it uses DL-165 chipset, and for DL-1xx chips you won't need the EVGI driver + new DisplayLink driver. You can use the udl kernel driver and it even works along with the proprietary nvidia drivers.

See more: https://wiki.archlinux.org/index.php/DisplayLink and http://www.displaylink.org/forum/showthread.php?p=81545#post81545

Still have some issues though: Giant virtual monitor with DispayLink monitor + Xfce with additional annoying scroll effect

0

My display-link on Ubuntu 16.04 only worked with nouveau and Unity (not xfce, gnome etc). With nvidia driver I couldn't even see the external displays/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.