2

I have installed Ubuntu Desktop 13.10 on a 250GB SSD which works OK. I also have a 2 TB HDD where I have my Virtualbox disks installed and when I boot the 2TB does not mount. When I hover over the drives in Files, the SSD is mounted, but the 2TB drive says "2 TB: Mount and open 2TB". If I click the drive the files appear and Virtualbox loads the guest OK.

I followed the steps in Is there a program to mount all of my drives automatically?. If I turn off the slider and click the mount automatically then reboot, the system tells me it cannot mount the drive. Clicking "S" continues boot, then I manually mount the 2TB.

What's puzzling is there is an eject button in Files on the 2TB drive. Has this drive somehow been added as removable like a USB drive?

3/18/15: After @organic-marble's comment about fstab I tried deleting/re-creating the partition, no help. Tried mounting the drive with the options added by the Disks program and received this error:

Error mounting system-managed device /dev/sda1: Command-line 'mount "/mnt/46d5deb0-05ac-4031-9ca6-f7fe4af6f024" exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepageor helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

dmesg | tail revealed:

377.111993 EXT4-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value.

Found this article on a bug: Fails to auto-mount device & Error mounting system managed device(Ubuntu 14.04) Changed x-gvfs-show option to comment=x-gvfs-show and it now mounts and shows in the user interface.

I copied my Virtualbox virtual disk file back to the drive and receive an error that I'll have to research it. Since the mount point changed after re-creating the drive it won't recognize the old file.

thanks to all who answered.

  • Have you tried editing fstab to add the drive? help.ubuntu.com/community/Fstab – Organic Marble Mar 16 '15 at 19:54
  • I get the eject button for every device (usb, hdd partitions, everything) I can unmount. I think that is normal. – Byte Commander Mar 16 '15 at 20:43
  • Thank you @OrganicMarble, when I check mounting options for the drive in Drives and turn "Automatic Mount Options" off, and check "Mount at Startup", it adds the drive to the fstab file but fails to mount when booting. The drive is accessible once the system is booted. I wonder if it has something to do with the speed the system boots with a Xeon processor and an SSD boot drive and maybe the drive isn't ready. I may try deleting and re-creating the drive to see if that helps. – David Gibson Mar 18 '15 at 18:37
  • I haven't ever used Drives so I wasn't familiar with that, I have always just edited fstab directly. Glad you got it working. – Organic Marble Mar 19 '15 at 1:54
  • 1
    @OrganicMarble Well, Drives is probably for noobs (like me) but I can sure see the advantages of knowing how to edit fstab directly, all in good time. The more I work with Linux, the more I want to move to it. Thank you for your assist. – David Gibson Mar 20 '15 at 2:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.