I'm aware of this other question and i'm making a new one because that solutions there were not enough for my problem.

I installed xfce and pcmanfm on top of my vanilla ubuntu 10.10 installation. After i got tired of them i uninstalled them. And then in some programs (gnome-do, firefox, file-browser-applet, chrome) i get the error

could not display the file'filename.txt' "the location is not a folder"

when trying to open files that those programs manage.

As suggested by the previously mentioned question i tried:

sudo apt-get remove exo-utils

Not no avail, i got ubuntu Tweak and went to the file associations tab, and the folder filetype is set to open-folder is that ok?

Also i checked these files


And they are the same as a clean 10.10 installation(i checked it with a virtual machine) I tracked it to

gnome-open 'the name of some file.pdf'

And i get the same error, and i'm guessing that the programs sending that error are using some function() that calls gnome-open or something like that. I also tried using the "exo-preferred-applications" to switch to nautilus, but it doesnt show the file-manager option as some suggested it would.

Right now i don't have the exo utils or anything exo installed, nothing Xfce specific. I ran out of things to try, so any help is appreciated.


I tried installing the package XFCE and then login to that desktop and gnome-open works on xfce... strange Also i got all the files on /usr/share/desktop from a clean 10.10 installation and copied over the files on my damaged installation and it didn't helped, is not an issue with them...


Finally got it! I deleted my ~/.gconf/desktop/gnome/url-handlers folder and now the problem is completely gone.

If you are interested, this was the source of the idea.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.