0

I was trying to setup a pxe boot server on my macbook air (http://hints.macworld.com/article.php?story=20130625164022823). MBA is connected to wifi while client machine is connected to wifi router using lan. But even after the setup and using ubuntu netbook images client machine seem not be picking up pxe image. My client machine(which is a desktop) has PXE capabilities for sure with wake on LAN. Is there anyone who tried this or similar sort of things.

  • and one more thing in my installation following the link i replaced the ip 192.168.1.1 with 192.168.1.3 (MBA ip), while ips 192.168.1.0 i left untouched. I tried some combos of them but nothing worked – rohit Mar 16 '15 at 12:14
0

Are you sure the macbook is handling the DHCP request and not your router? This is important because you have to set some options in your DHCP configuration which makes clients connect to the PXE server. In your config file on the MBA (bootpd.plist) these are options 66 and 67:

<key>dhcp_option_66</key>
        <string>192.168.1.3</string>
<key>dhcp_option_67</key>
        <data>cHhlbGludXguMAA=</data>

Also make sure that you edited the 192.168.1.1 to 192.168.1.3 in this file

| improve this answer | |
  • DHCP request are handled by the router. I tried with below config : <key>name</key> <string>192.168.1</string> <key>net_mask</key> <string>255.255.255.0</string> <key>net_address</key> <string>192.168.1.0</string> <key>net_range</key> <array> <string>192.168.1.2</string> <string>192.168.1.254</string> </array> <key>allocate</key> <true/> <key>dhcp_option_66</key> <string>192.168.1.3</string> <key>dhcp_option_67</key> <data>cHhlbGludXguMAA=</data> as pointed by you, but it didn't work – rohit Mar 16 '15 at 12:53
  • DHCP must be done by your MBA, if not the client will not get the option 66 and 67 setting. Try turning of DHCP on your router. – DriesSw Mar 16 '15 at 12:58
  • That seems magical, a single checkbox unchecked and all my struggle of past 3 hrs is resolved. Thanks – rohit Mar 16 '15 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.