8

When VLC Media player is used for playing 720p+ videos, it starts out fine. But when we seek, it stops producing any sound at all (like the player is in mute) and when we seek for couple of times more sound returns. Problem occurs every time in Ubuntu (most of the recent versions). I am thinking it might be specific to hardware (not sure). VLC works perfectly in my secondary OS in the same hardware (windows) so the hardware is not faulty.

This problem is already reported by many people but none has posted any solution. If you have any workaround or permanent fix for this, Please post..

Note: installed VLC pulse audio plugin - Didn't fix the problem

Hardware tested and issue found to be in;

  1. Intel motherboard DH77kc
  2. Lenovo G50 board
  • I have the same issue. When running via CLI with -vvv I get the following error output information images.programster.org/uploads/big/… – Programster Jul 16 '15 at 13:27
  • 2
  • That thread is locked and this thread has new info. Please refer below info "This problem is already reported by many people but none has posted any solution. If you have any workaround or permanent fix for this, Please post.." For the answer given in the other post - "This fixes the problem temporarily. After completing the video and exiting the player, when we open some other video: "Audio output failed: The audio device "plughw:CARD=Generic,DEV=0" could not be used: Device or resource busy." - This error message is obtained" – Parithy Sivakumar Apr 6 '16 at 6:41
8

After some googling I found this bug report on launchpad in which someone posted a "workaround" that is working for me.

enter image description here

Configured VLC with the settings below by going to Tools->preferencs.

enter image description here

Then click save and close all VLC instances before re-launching your video. Now you can seek without ever losing audio.

  • It did fix the problem. But now the sound feels like radio. Also after seeking there is a brief noise. – Likhon Nov 6 '15 at 5:31
1

Try to disable and then allow audio track in Audio -> Audio Track.

1

I found a way to have back the audio:

right click on the video / audio / Stereo mode, Stereo should be selected. Click another stereo mode, e.g. Reverse stereo and enjoy.

Repeat the operation each time you seek if needed. This is what I do since I have the same issue.....I hope it will help even though is not fixing the root of the problem.

Bye!

0

Go to tools preferences audio and then set the output to ALSA audio output then a new option labeled device pops up set it "PulseAudio sound server" or "playback/recording through the PulseAudio sound server". Restart vlc test it out

  • This fixes the problem temporarily. After completing the video and exiting the player, when we open some other video: "Audio output failed: The audio device "plughw:CARD=Generic,DEV=0" could not be used: Device or resource busy." - This error message is obtained. – Parithy Sivakumar Nov 12 '15 at 6:51
0

The issue is no longer present in the VLC version 2.2.2 on Ubuntu 16.04 even with the default settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.