1

I'm using Ubuntu 14.04,Processor Intel® Core™2 Duo CPU P8700 @ 2.53GHz × 2 . Here I have a issue like keys are not working properly. To type a letter I need to press that key for some time. I tried after installing gnome also, still same issue. This is happening only after login. And I tried with external usb keyboard also still not working. I doubt after apt-get update something happened. Please help me.

Edited

I have tried 'onboard' also. When I press keys on it using mouse nothing happening. So I think issue is related to OS only.

8

I fixed the issue. Somehow the Slow Keys option from System Settings → Universal Access → Typing was on. Thanks to this question's accepted answer.

enter image description here

| improve this answer | |
  • saved my day :) – Mukundhan Sep 5 '19 at 11:47
4

You might want to check the system statistics after logging in using top command. Ensure that no programs are eating your RAM. This may cause your keystrokes to take few more seconds to respond.

Now ensure that the problem is not with OS and it is because of the hardware. For this you can use the onboard utility comes with ubuntu. It might look like this.enter image description here

Verify that all the keystrokes are accepted by the OS properly.

| improve this answer | |
  • I tried onboard, that also not working. – Pramod Mar 16 '15 at 11:44
2

Open keyboard setting by searching keyboard in dash

enter image description here

Click on keyboard

enter image description here

Check both checkboxes and decrease delay and increase speed.

| improve this answer | |
  • Its both are checked. – Pramod Mar 16 '15 at 11:56
  • I had this issue and had to uncheck and then re-check the "Key presses repeated when key is held down" to resolve it. – Matt Pitkin Sep 14 at 13:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.