4

So tonight I flashed my Nexus 7 with Ubuntu Touch, however I'm having an issue. My wireless is protected with a 63 character WPA2 password. Whenever I try typing it in manually and hit "Connect" nothing happens, I'm guessing because I just take too long to enter the password. Whenever I try putting the password in the terminal it just bumps down to a > prompt, like I have unclosed quotes, even if I try enclosing the whole password in double quotes. There's no "paste" option in the guified way to connect to the wireless, so I'm really at a loss as to how I can leave my wireless protected AND get the password punched into Ubuntu Touch, :-(

Works fine if I turn off the password.

  • So I have tried manually copying my network profile from /etc/NetworkManager/system-connections on my Ubuntu laptop to the same folder on my Ubuntu Touch device, removed the old files on the Touch device from attempts to connect, set the permissions to be identical, removed the MAC address field from the file, and then rebooted the device, and it still doesn't connect. – Gerowen Mar 16 '15 at 7:47
  • I'm assuming the Nexus 7 has a WPS feature.. Why don't you try that instead if your router or the device which produce internet has WPS.. :) – AzkerM Mar 16 '15 at 7:57
  • Probably this bug: bugs.launchpad.net/canonical-devices-system-image/+bug/1445630 – quazgar Aug 3 '16 at 14:28
1

had the same problem today and found your thread^^, so I started myself to solve the problem. I did the same as you did, except I used the conf file from the phone and put the psk in. The file should look like this and is in /etc/NetworkManager/system-connections/

[connection]
id=<<<FILE NAME HERE(SSID>>>
uuid=<<< HERE IS A UUID>>>
type=802-11-wireless

[802-11-wireless]
ssid=<<<SSID HERE>>>
mode=infrastructure
mac- address=<<<MAC ADDRESS HERE>>>
security=802-11-wireless-security

[802-11-wireless-security]
key-mgmt=wpa-psk
auth-alg=open
psk=<<<PASSPHRASE HERE>>>

[ipv4]
method=auto

[ipv6]
method=auto

thats it. I copied the file with the shell app to ~/Documents so I could use Kate to edit it. chmod 777 is your friend. when you put it back chmod 600. Then I restarted the phone, but I don't know if it's necessary.

P.S. This is for WPA/WPA2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.