I have a single boot Acer laptop where I performed a clean installation of Ubuntu.

After boot it shows a bootable device not found error.

I tried running boot-repair and when it finishes it says that repair was successful, but the error persists.

The laptop did not have any operating system previously installed on it.

I also tried to deactivate UEFI, but the desktop would not load correctly making it impossible to install.

Any ideas on how to fix it?

  • so what error do you get when you boot ? – Panther Mar 15 '15 at 23:36
  • 2
    A shot in the dark: Try disabling Secure Boot. Note that Secure Boot is not synonymous with UEFI. In fact, given your configuration, it's best to boot in EFI/UEFI mode, so you should not attempt to disable UEFI (aka enable BIOS, CSM, or legacy support). You might also want to read this page I wrote on EFI-mode installs or this Ubuntu community wiki on the subject. – Rod Smith Mar 16 '15 at 1:42
  • bodhi.zazen -> The actual error is literally "Bootable device not". Rod Smith -> I couldn't find an option to disabling secure boot,only to disable UEFI, anyway I'll check it again and I'll post how it went. – Garoe Mar 16 '15 at 9:41
  • Any feed-back on the above? Disabling UEFI is definitely the way to go! – Fabby Mar 21 '15 at 15:45
  • Disabling UEFI lead to track pad ad other problems after install. The solution was to set up a bios password and the an option to manually add trusted boot files appeared. – Garoe Jun 26 '15 at 7:41

I got it work at Acer Aspire ES1-111-C827. Should be working on other devices, too. Probably the BIOS-entries are a bit different. All you have to do is to register the newly installed UEFI-file as trusted for executing in BIOS-security options.

Before installation goto BIOS-Settings, make sure to have this:

  • Security: set supervisor password;
  • Boot - BootMode: UEFI;
  • Boot - SecureBoot: enabled;

After installation again go to BIOS-Settings

  • Security - Select an UEFI file as trusted for executing, press Enter;
  • HDD0 appears, press Enter;
  • EFI appears, press Enter;
  • Go to <ubuntu> and press Enter;
  • Choose the first entry with .efi (shimx64.efi on my device) and press Enter;
  • Give it a name and press Enter;

Save changes on exiting BIOS and restart. That's it.

Some people report that they still needed to change the boot order.

  • Acer password setting: acer.custhelp.com/app/answers/detail/a_id/29349 – oldfred Aug 7 '15 at 15:36
  • It also worked for me to do all the above steps after installation. – ruquay Mar 9 '16 at 21:04
  • I followed the instructions; for some reason I don't get the 'Select UEFI file as trusted' option; although I can create the new boot with shimx64.efi as boot file; but it doesn't start the OS nevertheless. – Alex Dec 30 '16 at 0:25
  • Installing with UEFI (without CSM) and SecureMode, and then disabling SecureBoot and switching to UEFI (without CSM) after install made it work for me. – Script_Coded Jun 1 '18 at 5:18

protected by Community Aug 7 '16 at 18:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.