3

I have an acer aspire V5-573G which comes with a NVIDIA OPTIMUS chipset and 750M gfx card. I have a fairly fresh install of 14.04 and I have tried a number of things to install driver and CUDA. In the end nothing seems to work. I will give you a list of things I have done

  1. Install nvidia-340 driver which comes with prime. Then install CUDA toolkit without NVIDIA's proprietary driver. This works fine for once until you logout/restart. Anytime you switch to your NVIDIA card of prime, display goes black. I have tried a few things :

    i. Comment our the gpu-manager.conf file and make the intel gfx card modsetting. Make xorg.conf not wrieable through chattr. This still gives me a black screen.This method is outlined here.

    ii. Try to install the driver that comes with the CUDA toolkit. This always end up with the toolkit and samples being installed and not the driver. It is due to a linux header issue. I installed the headers but it still didn't solve the issue.

  2. Install bumblbee. Installing bumblebee with the driver and then purging prime led to the NVIDIA gfx card working with optirun of glxspheres64. But CUDA doesn't work. Whenever I run sudo optirun ./deviceQuery it gives me an error and tells me that nvidia-uvm isn't found

    This led me to believe I don't have the nvidia-340-uvm kernel module. So I used modeprobe to add it to the kernel and it says could not insert nvidia_340_uvm: No such device

This means I don't have 'nvidia'-340-uvm' right? WRONG. I try to install it via synaptic and it's already there part of the 340 probably part of the 340 driver.

So if anyone has got CUDA working with a optimus latop (especially a 700M series or above PLEASE HELP ME)

I am not sure about using nvidia-331 and CUDA 5.5 because 14.04 might not work with CUDA 5.5

  • I'm not sure how you're trying to install the nvidia-340 driver. try searching for "software and updates" in the dash (the big button up to the left) and going to the "additional drivers" tab. – Mina Michael Mar 15 '15 at 21:34
  • Yeah. I just installed it via the terminal. It should be the same thing – Isuru Daulagala Mar 15 '15 at 21:41
  • ah yes. same thing from terminal ...well did it work? – Mina Michael Mar 16 '15 at 7:49
  • Unfortunately it didn't work. I'm still stuck with a black screen as soon as I switch to the NVIDIA card – Isuru Daulagala Mar 18 '15 at 0:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.