1

i am very new to Ubuntu Apache2 World. I have a Apache2 in my Ubuntu Server (14.04) in my home installed. I tried to visit this Apache Server in my LAN environment. (Server IP is static: 192.168.0.105).

My Problem is: I enter 192.168.0.105 in my laptop, I can visit the Apache2, but I write my Apache ServerName(www.pigeontest.de), it will not work... My works were like below:

  1. I set "Server Name" under /etc/apache2/sites-available/pigeontest.de.conf already like below: ![ ServerAdmin webmaster@ubuntu.lan

      ServerName www.pigeontest.de
      ServerAlias pigeontest.de
    
      DocumentRoot /var/www/html/pigeontest.de
    

    Options Indexes
    DirectoryIndex index.php index.html AllowOverride All Order allow,deny Allow from all Require all granted

      ErrorLog ${APACHE_LOG_DIR}/pigeontest.de/error.log
      CustomLog ${APACHE_LOG_DIR}/pigeontest.de/access.log combined
    

]1

  1. Then I did: sudo a2ensite pigeontest.de.conf
  2. Then I goto "sudo vim /etc/hosts": 127.0.0.1 localhost
    127.0.1.1 UbuntuServer www.pigeontest.de

The following lines are desirable for IPv6 capable hosts

::1 localhost ip6-localhost ip6-loopback

  1. Then sudo service apache2 reload
  2. Then sudo service apache2 restart

IT NOT WORKS! I do not know why...Thank you for help!

0

Looks like there is a domain name related issue.

Are you sure you set your domain name provider's nameserver settings to point to the hosting provider's domain servers?

For example, assume you use digitalocean for hosting, you need to go to the control panel of domain name registrar, find fields named "Domain Name Server" and set their values to 'ns1.digitalocean.com', 'ns2.digitalocean.com' and 'ns3.digitalocean.com'.

Also, you can verify if you did it successfully by whois.

p.s.: It may take an hour or two for the changes to be reflected on your site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.