1

On a new elementary os installation the swap is not available. I tried all the remedies offered here: What to do about "the disk drive for /dev/mapper/cryptswap1 is not ready yet or not present"? but nothing seems to do the trick. After I run all the steps and reboot the same message appears and prior to rebooting the swap indeed shows in 'free -m'.

After rebooting it shows: Mem: 1613 1028 584 0 34 504 -/+ buffers/cache: 488 1124 Swap: 0 0 0 I too had to reboot between formatting the partition as linux-swap in gparted as otherwise it wouldn't do it.

What else to try, nothing seems to help...?

  • Are you using 14.04? Things changed between 12.04 and 14.04, so any answers from before 14.04 are unlikely to fully cover the issues you would be facing in 14.04. Also this sounds like a possible duplicate of askubuntu.com/questions/596813/… – kasperd Mar 15 '15 at 13:26
  • Does askubuntu.com/a/597153/284919 work for you? – kasperd Mar 15 '15 at 17:18
  • @kasperd Wonderful, the first one did it :) It still shows the crappy mistake while booting but swap is now on: 'Swap: 1952 0 1952' – merlin Mar 16 '15 at 9:22
  • We're sorry, but this site is all about Ubuntu and its official derivatives as posted on wiki.ubuntu.com/Releases so Elementary Luna is off-topic here as well. However, on unix.stackexchange.com, a sister site to Ask Ubuntu, they're very good at all varieties of Linux and Unix, so you might be better off there. ;-) – Fabby Mar 21 '15 at 15:34
  • 1
    That's fab, @Fabby :) thank you very much - will use the new site for any further questions – merlin Mar 23 '15 at 6:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.