2

nm-applet always gives me a hard time when connecting to wireless. I often have to restart it and make several attempts till it connects to a network. Sometimes even restarting the computer doesn't help. This time I ran it from CLI and I got this:

** (nm-applet:2950): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-t6ky00XpYq: Connection refused

    ** (nm-applet:2950): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: The name org.freedesktop.NetworkManager was not provided by any .service files

    (nm-applet:2950): nm-applet-WARNING **: Failed to register as an agent: (2) The name org.freedesktop.NetworkManager was not provided by any .service files

    (nm-applet:2950): nm-applet-WARNING **: Failed to register as an agent: (2) The name org.freedesktop.NetworkManager was not provided by any .service files

Here is the output of lspci -knn | grep Net -A2

02:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev 93)
    Subsystem: Intel Corporation Device [8086:5070]
    Kernel driver in use: iwlwifi
  • It seems to arise from this bug: github.com/gtimelog/gtimelog/issues/27 – Reza Apr 3 '15 at 17:32
  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. – Pilot6 Jul 20 '15 at 9:40
  • So from reading comments , I know you restart network-manager and nm-applet to make it work (sudo service network-manager restart ). I suggest you make those commands an autostart entry to be run on every graphical login. Another alternative - switch from network-manager to wicd. It's less pretty but it works. Helped me when my networking went down the drain. Among other things, look into updating your driver and upgrading to 4.0 kernel – Sergiy Kolodyazhnyy Jul 22 '15 at 21:12
  • Have you tryed this: nmcli -c -d (the lan ip adr) --force-yes and it might work fine this way. – Michael Jul 25 '15 at 15:47
0
  • org.freedesktop.NetworkManager service file is provided by network-manager package.

    $ grep -rl NetworkManager /etc/dbus-1/ /usr/share/dbus-1/
    /etc/dbus-1/system.d/nm-pptp-service.conf
    /etc/dbus-1/system.d/nm-strongswan-service.conf
    /etc/dbus-1/system.d/nm-vpnc-service.conf
    /etc/dbus-1/system.d/nm-openvpn-service.conf
    /etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf
    /etc/dbus-1/system.d/nm-iodine-service.conf
    /etc/dbus-1/system.d/nm-openconnect-service.conf
    /usr/share/dbus-1/system-services/org.freedesktop.nm_dispatcher.service
    
    $ dpkg -S /etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf
    network-manager: /etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf
    
  • Try reinstalling it then reboot

    sudo apt-get install --reinstall network-manager
    sudo reboot
    
  • No, didn't help. I restart the nm-applet and network manager each time I want to connect and then it works. – Reza Mar 22 '15 at 13:26
0
+50

The issue has nothing to do with Network Manager.

It is a problem with iwlwifi driver and your adapter.

It was reported that turning power saving feature of this adapter solves the problem. It can be done by running in terminal

sudo iwconfig wlan0 power off

But this setting will not stay after reboot.

I would turn it off in iwlwifi module by running

sudo tee /etc/modprobe.d/iwlwifi.conf <<< "options iwlwifi power_save=0" 

If turning off power save feature in iwlwifi module does not help, you can revert it by

sudo rm /etc/modprobe.d/iwlwifi.conf

And you can always add sudo iwconfig wlan0 power off to /etc/rc.local by running

sudo -H gedit /etc/rc.local

and adding sudo iwconfig wlan0 power off before exit 0 line.

This command will always run on boot.

Another kernel option that may help is options iwlwifi 11n_disable=1.

It can be set by

sudo tee /etc/modprobe.d/iwlwifi.conf <<< "options iwlwifi 11n_disable=1"
  • Power management is already off. I can't remember how I turned it off (which survives reboots) but the output of iwconfig shows that it's off. – Reza Jul 20 '15 at 12:43
  • I added another option that may help. – Pilot6 Jul 20 '15 at 12:47
  • @Reza And what is Ubuntu version? Did you update packages? It looks like new firmware is installed in May 2015. – Pilot6 Jul 20 '15 at 13:02
  • It's Trusty and it's up to date. This problem has survived many updates. – Reza Jul 20 '15 at 13:05
  • I did the last command you mentioned and have not had this problem since then. Don't know if the problem is solved or not but the deadline for the bounty was approaching. – Reza Jul 26 '15 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.