1

I have struggled for hours on end to fix a serious problem which started after the turn of the year. I cannot make Synaptic reload! I have read through the questions here as well as the answers. I have TRIED THEM ALL!

I am no novice to Linux! I started out with a half page of errors -- I've reduced it to ONE error that I cannot fix...

Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/trusty/main/binary-i386/Packages  Hash Sum mismatch
Some index files failed to download. They have been ignored, or old ones used instead. 

I do not have the above link anywhere in my system that I can find! "dists" or "binary" is simply not in my lists!

Below is a copy of my software sources list. Where does the above link come from?!

deb http://us.archive.ubuntu.com/ubuntu/ trusty main
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates main
deb http://security.ubuntu.com/ubuntu trusty-security main
deb http://archive.canonical.com/ubuntu trusty partner
# deb-src http://archive.canonical.com/ubuntu trusty partner
2

2 Answers 2

2

SOLVED!!!!

/var/lib/apt -- This was the real source of the problem. This was also where I actually located the mysterious files that kept showing up in the errors.

The first step is to MANUALLY delete thepartial folder. However, here is where something really weird happened. I opened the 'partial' folder and saw right away the troublesome error file—but before I could do anything, the troublesome file along with all other files in that same folder, one at a time, simply VANISHED in front of my eyes! I had a hunch at this point and without bothering the other files in the 'apt' folder I tried Synaptic again—it reloaded PERFECTLY! Then I systematically, one at a time, re-checked EVERYTHING in the repositories.

The moral of the story? Anytime you have BADSIG, Hash sum mismatch etc. the first thing you do is go to /etc/apt –open the lists with leafpad—wipe out everything! Replace this with a list made by Ubuntu repository creator.

NEXT go to /var/lib/apt, if there is a 'partial' folder DELETE it. If this does not work then COPY AND PASTE all other files in this folder to somewhere else, then delete all these files in the folder you just C&Pasted from—then—add them back one at a time till things work right.

DO NOT, I repeat, DO NOT attempt to delete these things using CLEAN or AUTOCLEAN or any such. MANUALLY DELETE these!!!!!

THE PROBLEM is in the CLEAN and AUTOCLEAN features of Linux-Lubuntu. There is a real GLITCH here!!!

I have 5 computers ALL with Lubuntu--ALL with exactly the same issue!!!

2
  • What is a partial folder? Mar 15, 2015 at 14:22
  • It is present in /var/lib/apt
    – rancho
    Jun 19, 2016 at 2:10
0

run in terminal

sudo apt-get update

Take a note of the ubuntu repositories which are giving the problem

Type in terminal

sudo apt-get install vim
cd /etc/apt
sudo vim sources.list

Identify those repositories and put a # in front of them to comment them out.

If they are non ubuntu repositories, do

cd /etc/apt/sources.list.d

Identify the problem repositories, then do

sudo mv repository-name.list repository-name.list.backup
sudo mv repository-name.list.save repository-name.list.save.backup

Remove the partial folder in /var/lib/apt

sudo rm -rf /var/lib/apt/partial*

Now update

sudo apt-get update

Go back to sources.list

sudo vim /etc/apt/sources.list

Uncomment the previously commented repositories by removing the # in front of them.

Go to sources.list.d and restore the backed up repositories

sudo mv repository-name.list.backup repository-name.list
sudo mv repository-name.list.save.backup repository.list.save

Do another update

sudo apt-get update

Hopefully problems will now get resolved

If you get any gpg key error, note down the keys being asked for. It is a sixteen character combination of uppercase letters and numbers. Then type in terminal

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com `sixteen-character-key`

Again do

sudo apt-get update

Hopefully the problems would get resolved now.

If you want you can make the process easier by doing the following

sudo add-apt-repository ppa:webupd8team/y-ppa-manager
sudo apt-get update
sudo apt-get install y-ppa-manager
sudo launchpad-getkeys

Have a happy experience with ubuntu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.