1

I try to connect to internet on my Laptop HP Pavilion using Ubuntu 14.10, but there is a problem that Ubuntu doesn't recognize the wired connection or the Ethernet adapter:

When I type ifconfig, it only shows:

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:181 errors:0 dropped:0 overruns:0 frame:0
          TX packets:181 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:13318 (13.3 KB)  TX bytes:13318 (13.3 KB) 

When typing ifconfig -a:

eth0      Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:181 errors:0 dropped:0 overruns:0 frame:0
          TX packets:181 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:13318 (13.3 KB)  TX bytes:13318 (13.3 KB)

While when I follow the instructions as at:

http://www.pcworld.com/article/2455972/how-to-fix-your-internet-connection-in-ubuntu-linux.html

First it says that the "Cable unplugged" for Wired connection - although the cable is connected- also the button "save" still closed even after editing manually the IPv4 Settings.

I tried to follow the answer on: Ubuntu Server wont recognize ethernet

And here are what I had :

ifconfig -a | grep eth gives:

eth0      Link encap:Ethernet  HWaddr 00:00:00:00:00:00  

sudo ifdown eth0 && ifup eth0 gives:

RTNETLINK answers: No such process
Internet Systems Consortium DHCP Client 4.2.4
Copyright 2004-2012 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

After nano /etc/network/interfaces:

auto eth1
iface eth1 inet static
address 192.168.1.3
netmask 255.255.255.0
gateway 192.168.1.1
dns-nameservers 8.8.8.8 192.168.1.1 

Then sudo ifdown eth1 && sudo ifup -v eth1 gave:

ifdown: interface eth0 not configured
Configuring interface eth0=eth0 (inet)
run-parts --exit-on-error --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/ethtool
run-parts: executing /etc/network/if-pre-up.d/wireless-tools
run-parts: executing /etc/network/if-pre-up.d/wpasupplicant
ip addr add 192.168.1.3/255.255.255.0 broadcast 192.168.1.255     dev eth0 label eth0
RTNETLINK answers: File exists
Failed to bring up eth0.

Changing eth1 to eth0:

safi@safi:~$ sudo ifdown eth0 && sudo ifup -v eth0
ifdown: interface eth0 not configured
Configuring interface eth0=eth0 (inet)
run-parts --exit-on-error --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/ethtool
run-parts: executing /etc/network/if-pre-up.d/wireless-tools
run-parts: executing /etc/network/if-pre-up.d/wpasupplicant
ip addr add 192.168.1.3/255.255.255.0 broadcast 192.168.1.255     dev eth0 label eth0
RTNETLINK answers: File exists
Failed to bring up eth0.

How should I proceed?

3
  • Why does /etc/network/interfaces refer to eth1 when your ethernet interface is eth0 according to ifconfig?
    – chili555
    Mar 14 '15 at 21:47
  • Oh,I typed for my pc ofcourse eth0, but here I took copy- past from the refered page. Any help in this ? It seems connecting my pc to internet under Ubuntu is not default.
    – S.S.
    Mar 15 '15 at 7:15
  • What is the output to lshw -c network?
    – Fabby
    Mar 20 '15 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.