8

Yesterday I bought new laptop Lenovo E540 and I installed here Ubuntu 14.04.2. But I've problem with my wifi (router is Dlink g version). I can connect to wifi without problems after turning on laptop. But then (after some time of work) suddenly my connection is lost, but network-manager is still signalizing that I'm connect but I can't even ping anything. When I try to reconnect via manager to my network it's looking like it's trying to connect but it will never do... I have to reboot and then everything is again correct until it will close connection again. I was searching net, but unfortunatily without luck. I tried to comment dns=dnsmasq in /etc/NetworkManager/NetworkManager.conf, but nothing happen.

on Jeremy31 suggestion here is a result of

lspci -nnk | grep -iA2 net

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
    Subsystem: Lenovo Device [17aa:5028]
    Kernel driver in use: r8169
04:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Lenovo Device [17aa:b728]
    Kernel driver in use: rtl8723be

when I used grep network-manager over syslog I found there some errors:

Mar 14 22:40:03 dano-lenovo NetworkManager[784]:  error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.23': no such name

but I think it's problem that I can't reconnect, but why this happend I'm not sure..

last logs before error are:

NetworkManager[784]:  (wlan0): IP6 addrconf timed out or failed.
Mar 14 22:38:31 dano-lenovo NetworkManager[784]:  Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
Mar 14 22:38:31 dano-lenovo NetworkManager[784]:  Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) started...
Mar 14 22:38:31 dano-lenovo NetworkManager[784]:  Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) complete.
Mar 14 22:38:31 dano-lenovo wpa_supplicant[909]: wlan0: CTRL-EVENT-SCAN-STARTED 

Tnaks for help

  • What wifi card? Please edit question to include the results from lspci -nnk | grep -iA2 net – Jeremy31 Mar 14 '15 at 17:33
  • Hello, thanks for response, I put result to my question.. thanks – DaMi Mar 14 '15 at 18:11
  • 2
    Possible duplicate of Realtek 8723BE Wifi problem – Pilot6 Oct 14 '15 at 14:26
5

you can try one of the below solution:

Open terminal and type in: sudo service network-manager restart.
OR
Go to System Setting -> Network -> Forget your wifi and reconnect to it.
OR
Restart or Log off and Log into your laptop.

  • 2
    I shouldn't have to do any of your suggestions. Why should it stop working? Are we not looking for a solution where it won't have to stop working, not when it happens, what I should do. Not sure if this answer is any useful – Rexford May 2 '18 at 13:23
4

My new Dell Inspiron laptop had the same issue: WiFi would work for a few minutes, then stop working. Adding

options rtl8723be fwlps=N ips=N 

to /etc/modprobe.d/rtl8723be.conf fixed the problem.

But then I saw How do I get a Realtek RTL8723BE wireless card to work? which seems a more definitive approach. So I did that instead (removing rtl8723be.conf as well), and that worked as well.

I'm a little uneasy using this "unapproved" WiFi driver, but it does seem to work.

  • 2
    Which options did you add and how? – Pilot6 Oct 14 '15 at 14:27
  • It is a driver from Realtek. I just made a ppa for it. – Pilot6 Oct 14 '15 at 15:54
0

This will install backported modules from the 3.19 kernel and it works well

sudo apt-get install linux-headers-generic build-essential
wget https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.19-rc1/backports-3.19-rc1-1.tar.gz
tar -zxvf backports-3.19-rc1-1.tar.gz
cd backports-3.19-rc1-1
make defconfig-rtlwifi
make
sudo make install

echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf Reboot

If you update and get a new kernel you need to do the following

cd backports-3.19-rc1-1
make clean
make defconfig-rtlwifi
make
sudo make install

EDIT: after seeing the wireless-info, I would change the encryption to WPA2 only with no TKIP

After changing encryption, if you want to try it without the backports cd ~/backports-3.19-rc1-1 and then sudo make uninstall reboot and if you feel it works better with the backports cd ~/backports-3.19-rc1-1 and sudo make install

  • Thanks a lot! I will try it... Can you tell me what is wrong now that is not working that I've to install backported modules? I'm just wondering what is wrong, because there was no problem on my previous laptop on lower ubuntu version. – DaMi Mar 14 '15 at 18:39
  • Not exactly sure but it seems to be an issue with every ubuntu kernel lately – Jeremy31 Mar 14 '15 at 18:46
  • Still not working. After reboot it happend again. When it happend I tried to ping my router address with result: ping 192.168.0.1 PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data. From 192.168.0.105 icmp_seq=1 Destination Host Unreachable where 192.168.0.105 is my address and 192.168.0.1 is router – DaMi Mar 14 '15 at 18:58
  • ubuntuforums.org/showthread.php?t=370108 This script will collect data from your wifi setup and compile it into a wireless-info.txt file. Copy the contents and paste at paste.ubuntu.com and post the URL from it – Jeremy31 Mar 14 '15 at 19:02
  • 1
    My last trick echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf reboot – Jeremy31 Mar 14 '15 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.