4

After installing Ubuntu Server 14.04.2 LTS without any errors I tried to boot into my PC and then I just got to a blank screen with a blinking underscore. There was no input except for CTRL + ALT + DEL which restarted the computer (as far as I have tested).

My mother board is ASUS - P9X79 WS.

I have a NVIDIA Graphics card (Don't remember the product name, but I've read that NVIDIA or AMD Graphic cards can cause the black screen problem)

I am not using any dual boot.

I have tried tampering around with the boot settings quite a lot, CMS, Secure boot, AHCI, etc.

I can get everything to work and boot into the system if I enter BIOS and boot into Generic Flash Drive (without UEFI) the monitor goes into standby for like 5 seconds then goes on and just shows a black screen for another 5 seconds and then I am presented with the login screen for Ubuntu Server. (I never saw any sign of GRUB or some sort of start up output).

The flash disk I used was the installation disk, but I don't really know if it would matter if I would use a random disk and boot from it because there seems to be no sign of any kind of interface.

I really don't understand how this worked but it did, but it isn't a long term solution because I can't restart the server remotely, and I need to enter bios and selecting Generic Flash Drive each time. (Changing the boot order did not work).

If I boot into the USB Disk with UEFI I get to the Ubuntu Server installation/recovery menu.

5

It sounds like you've installed in BIOS/CSM/legacy mode but your computer is configured to boot in EFI/UEFI mode by default. The easiest solution is to enter your firmware and reconfigure it to boot in BIOS/CSM/legacy mode by default. Unfortunately, I can't give you exact step-by-step instructions because the procedure to make this change varies from one computer to another. You've clearly already activated BIOS/CSM/legacy support, but you may need to change the boot order or disable EFI/UEFI support to get the behavior you want.

Another approach is to install whatever EFI boot loader for Linux appeals to you. Ubuntu uses GRUB2 by default (for both BIOS and EFI), and you can install that by running Boot Repair; however, it's best if you do this from EFI mode, which means you'll need to boot an emergency system into EFI mode or boot your installed system in EFI mode in some other way. You can do the latter with a USB flash drive or CD-R version of my rEFInd boot manager. If you like rEFInd, you could install it to your hard disk via dpkg or the PPA; it would then take over from GRUB. Given your setup, installing any EFI boot loader might require you to create an EFI System Partition (ESP); it's not clear if you've got one.

In the future, be aware that most modern computers support both BIOS-mode booting (via the CSM) and EFI-mode booting. This flexibility is useful in some cases, but it can also lead to problems such as the one you're experiencing. IMHO, it's usually best to disable the CSM (aka legacy-mode support). This will force an EFI-mode boot of the Ubuntu installer, which will then install an EFI-mode version of GRUB. Closing off the BIOS/CSM/legacy boot options makes it less likely that you'll have problems of this sort. The downside is that a lot of tools for creating Ubuntu install disks don't write EFI boot loaders by default; you've got to use either dd (to copy the image file straight to disk) or an EFI-aware tool for creating your boot media. If you decide to re-install Ubuntu, I recommend doing so in EFI mode.

3

When you boot, you are always taken into the GUI terminal. Unfortunately, this varies from one computer to another.

One way of experimenting with this is try installing the desktop

sudo apt-get install ubuntu-gnome-desktop

If this works, then the problem is that your computer takes you by default to GUI terminal on booting. Press CTRL+ALT+F1. This will take you to command-line terminal.

  • 1
    THANK YOU! I was going to retry the install process, but this got me right into the command line. For those who come after... my screen originally said ‘OS: clean, files: xxx/yyy’, and seemingly no input was allowed. This answer got me to the right place. – Danny Harding Jan 24 '18 at 14:27
1

Ubuntu server is a non gui OS (only terminal window OS), it doesn't have windows, for your computer you must install Ubuntu desktop.

http://www.ubuntu.com/download/desktop

scroll down and download version 14.10 64 bit version.

  • 2
    It's possible to add a GUI to Ubuntu Server by installing appropriate packages. Typing apt-get install unity will probably get most of what you need, although I can't promise that. In any event, the boot problems reported by Mini are unrelated to the Ubuntu version, so installing the Desktop version won't really change anything. – Rod Smith Mar 15 '15 at 17:00
1

With 14.04 installed from USB drive I noticed the installer installs GRUB on sda which is the USB (installer) drive. The hard drive is sdb during install. So boot the machine with the USB drive and do a grub repair on the hard drive. Now the system will boot without the USB drive. 16.04 now gives you the option of choosing what drive Grub gets installed to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.